X11 Error: Can't open display: :0.0

Hello! I’ve read through a few forum posts and have tried redoing the WSL steps. I originally tried with WSL 2 and it wouldn’t work. I swapped to WSL 1 and it’s still not working. Additionally, I ensure that I open/setup XForward before opening Ubuntu and I am working from Windows OS (v10.0.19041). Here is the output! I appreciate any and all help.

hananguzman@Hanan:~$ afni_system_check.py -check_all
-------------------------------- general ---------------------------------
architecture:         64bit
system:               Linux
release:              4.19.104-microsoft-standard
version:              #1 SMP Wed Feb 19 06:37:35 UTC 2020
distribution:         Ubuntu 20.04 focal
number of CPUs:       8
apparent login shell: bash
shell RC file:        .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni           : /home/hananguzman/abin/afni
afni version         : Precompiled binary linux_ubuntu_16_64: Sep  1 2020
                     : AFNI_20.2.16 'Aulus Vitellius'
AFNI_version.txt     : AFNI_20.2.16, linux_ubuntu_16_64, Sep 01 2020
which python         : /usr/bin/python
python version       : 2.7.18rc1
which R              : /usr/bin/R
R version            : R version 3.6.3 (2020-02-29) -- "Holding the Windsock"
which tcsh           : /usr/bin/tcsh

instances of various programs found in PATH:
    afni    : 1   (/home/hananguzman/abin/afni)
    R       : 1   (/usr/bin/R)
    python  : 1   (/usr/bin/python2.7)
    python2 : 1   (/usr/bin/python2.7)
    python3 : 1   (/usr/bin/python3.8)

testing ability to start various programs...
    afni                 : success
    suma                 : success
    3dSkullStrip         : success
    uber_subject.py      : success
    3dAllineate          : success
    3dRSFC               : success
    SurfMesh             : success
    3dClustSim           : success
    3dMVM                : success

checking for R packages...
    rPkgsInstall -pkgs ALL -check : success

R RHOME : /usr/lib/R

checking for $HOME files...
    .afnirc                   : found
    .sumarc                   : found
    .afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** failed to load module PyQt4
-- PyQt4 is no longer needed for an AFNI bootcamp

** failed to load module matplotlib.pyplot
-- matplotlib.pyplot is not required, but is desirable

-------------------------------- env vars --------------------------------
PATH = /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/mnt/c/Program Files/WindowsApps/CanonicalGroupLimited.UbuntuonWindows_2004.2020.812.0_x64__79rhkp1fndgsc:/mnt/c/Program Files (x86)/Common Files/Oracle/Java/javapath:/mnt/c/Program Files (x86)/Intel/Intel(R) Management Engine Components/iCLS/:/mnt/c/Program Files/Intel/Intel(R) Management Engine Components/iCLS/:/mnt/c/Windows/system32:/mnt/c/Windows:/mnt/c/Windows/System32/Wbem:/mnt/c/Windows/System32/WindowsPowerShell/v1.0/:/mnt/c/Program Files (x86)/Intel/Intel(R) Management Engine Components/DAL:/mnt/c/Program Files/Intel/Intel(R) Management Engine Components/DAL:/mnt/c/Program Files (x86)/Intel/Intel(R) Management Engine Components/IPT:/mnt/c/Program Files/Intel/Intel(R) Management Engine Components/IPT:/mnt/c/Program Files (x86)/Common Files/Seagate/VirtualFile/:/mnt/c/Program Files (x86)/Common Files/Seagate/VirtualFile64/:/mnt/c/Program Files (x86)/Common Files/Seagate/SnapAPI/:/mnt/c/Program Files (x86)/NVIDIA Corporation/PhysX/Common:/mnt/c/Program Files/NVIDIA Corporation/NVIDIA NvDLISR:/mnt/c/WINDOWS/system32:/mnt/c/WINDOWS:/mnt/c/WINDOWS/System32/Wbem:/mnt/c/WINDOWS/System32/WindowsPowerShell/v1.0/:/mnt/c/WINDOWS/System32/OpenSSH/:/mnt/c/WINDOWS/system32:/mnt/c/WINDOWS:/mnt/c/WINDOWS/System32/Wbem:/mnt/c/WINDOWS/System32/WindowsPowerShell/v1.0/:/mnt/c/WINDOWS/System32/OpenSSH/:/mnt/c/Users/hanan/AppData/Local/Microsoft/WindowsApps:/snap/bin:/home/hananguzman/abin

R_LIBS = /home/hananguzman/R


------------------------------ data checks -------------------------------
data dir : found AFNI_data6   under $HOME
           top history: 20 Feb 2020 [rickr]: updated FT_analysis examples
data dir : found AFNI_demos   under $HOME
           top history: 22 Oct 2019 [discoraj]: added Cluster Explorer Demo
data dir : found suma_demo    under $HOME
           top history: ...s_New/data/Build_tmp on Mon Mar  4 11:56:45 EST 2013
data dir : found afni_handouts under $HOME
atlas    : found TT_N27+tlrc  under /home/hananguzman/abin

------------------------------ OS specific -------------------------------
which apt-get        : /usr/bin/apt-get
apt-get version      : apt 2.0.2ubuntu0.1 (amd64)

have Ubuntu system: Ubuntu 20.04 focal
have Ubuntu afni  : Precompiled binary linux_ubuntu_16_64: Sep  1 2020

=========================  summary, please fix:  =========================
*  just be aware: login shell 'bash', but our code examples use 'tcsh'

hananguzman@Hanan:~$ afni
Precompiled binary linux_ubuntu_16_64: Sep  1 2020 (Version AFNI_20.2.16 'Aulus Vitellius')

** Version check disabled: AFNI_VERSION_CHECK forbids
Thanks go to BD Ward for great efforts

Initializing: X11Error: Can't open display: :0.0
++ AFNI is detached from terminal.
hananguzman@Hanan:~$ suma

     No input specified, loading some toy surfaces...
     Use '.' and ',' to cycle between them.
     See suma -help for assistance.

Error: Can't open display: :0.0


Yes, using WSL 1 is necessary for a Windows OS of that version number.

What is the output of the following if you copy+paste the following funny command into a WSL terminal:

grep -E 'DISPLAY|BRIDGE' ~/.*rc

(That is to check sure that step #4 here has been done:

Secondly, have you installed the VcxSvr, as described in step #1 of the above link, and have you also started it running before opening your terminal?