Hello I am trying to install the programs necessary to open uber_subject.py but its been almost impossible. Would you mind to give me any advices please?
Here is my afni_system_check.py output

Thank you

------------------------------ OS specific -------------------------------
XQuartz version : 2.7.11

which brew : /usr/local/bin/brew
brew version : Homebrew 2.4.3

++ found PyQt4 under /usr/local/lib/python2.7/site-packages
** warning: have brew? PyQt4, but non-brew python /Users/lbohorquez/miniconda3/bin/python
++ found 1 dylib files under ‘/opt/X11/lib/flat_namespace’
– found ‘libXt’ dylib files:
** env var DYLD_LIBRARY_PATH is not set to contain /opt/X11/lib/flat_namespace
(so afni and suma may fail)

========================= summary, please fix: =========================

  • login shell ‘bash’, trusting user to translate code examples from ‘tcsh’
  • have python version 3.7.6, some programs need 2.7.x
  • insufficient data for AFNI bootcamp
  • OS X version might be old
  • consider setting DYLD_LIBRARY_PATH to /opt/X11/lib/flat_namespace


Before saying anything else, it has been years since I have run uber_subject.py on a mac. It might work, it might not.

Note that you are running python 3.7, yet PyQt4 was found for python 2.7. So it would be necessary to either install PyQt4 for python 3.7 (i.e. under /usr/local/lib/python3.7/site-packages), or use python 2.7 (which is hard to suggest, since it is no longer supported).

In any case, we highly suggest becoming more familiar with afni_proc.py directly, as uber_subject.py does not have interfaces for many of the more modern options in afni_proc.py.

  • rick

ohh ok Rick! thank you so much for your answer