rPkgsInstall -pkgs ALL

Hi all
As bad download speed in our lab, I did not know whether this step was done appropriately (windows 10 subsystem ubuntu 16.04). So I prefer install packages one by one manually. Can anyone tell me which packages( and version) in R (version 3.4.3) were needed for AFNI program?

So, as far as the packages, they are:

‘afex’, ‘phia’, ‘snow’, ‘nlme’, ‘lme4’,‘paran’, ‘psych’

… as for the version number(s), well, I just had some issues yesterday with afex on a new comp (a Mac- ugh) that I was installing on; apparently, afex has juuuust been updated, and there is some hassle about dependencies with ‘Hmisc’ and ‘viridis’. I haven’t had time to look deeper into this. I think the newest afex is 0.19; the older one is 0.18, but I still wasn’t getting full traction from that.

So, you can go ahead with things as are, and that should get you most of the way, if not all of the way, there on the packages.

Please search for “Example 2” and “Example 3” in the rPkgsInstall help file for examples about individualized package installation with that function, and also for the ability to specify a download site.


I see. Thanks.
Another question: The command displayed some message after running afni_system_check.py -check_all. How can I fix it?

------------------------------ OS specific -------------------------------
which apt-get : /usr/bin/apt-get
apt-get version : apt 1.2.24 (amd64)

have Ubuntu system: Ubuntu 16.04 xenial
have Ubuntu afni : Precompiled binary linux_ubuntu_16_64: Jan 11 2018

========================= summary, please fix: =========================

  • login shell ‘bash’, trusting user to translate from ‘tcsh’

That isn’t an error message, that is just a choice; users can use either the “bash” or “tcsh” shell. This doesn’t affect running AFNI; there is just a different style of syntax for setting variables, for example:

# in tcsh: use keyword "set", and can have spaces
set a = 20
echo $a

# in bash: no keyword, can*not* have spaces
echo $a

To know which shell you are currently using, you can type:

echo $0

If you really want to change to tcsh as default, doing so in Linux is described in the install instructions here:
(In Mac, some different steps are necessary.)