Resting state scripts: 3dToutcount cannot open dataset

Hi AFNI experts,

I currently preprocessed resting state fMRI data following the example 11a.

However when I used the generated proc. script, it ended soon with the following information:

++ elapsed time = 2.5 s
set tr_counts = ( 200 )
cd tracy_in2.results
touch out.pre_ss_warn.txt
foreach run ( 01 )
3dToutcount -automask -fraction -polort 3 -legendre pb00.tracy_in2.r01.tcat
++ 3dToutcount: AFNI version=AFNI_17.1.09 (Jun 6 2017) [64-bit]
** Can’t open dataset pb00.tracy_in2.r01.tcat

I have tried several datasets. All generated the same errors. I’l like to ask what’s wrong with the script or others? Many thanks!

Best regards,

Hi Tracy,

It is a little strange not to see a view (e.g. +orig) on the
input dataset. Is that script directly from, or
was it modified?

What is an example of a dataset that was used as input
to the command?

  • rick

Hi Rick,

Yes, I modified a little bit, the scripts are as follows: -subj_id tracy_in1
-blocks despike tshift align tlrc volreg blur mask regress
-copy_anat SUMA/tracy_SurfVol.nii
-anat_follower_ROI aaseg anat SUMA/aparc.a2009s+aseg.nii
-anat_follower_ROI aeseg epi SUMA/aparc.a2009s+aseg.nii
-anat_follower_ROI FSvent epi SUMA/tracy_vent.nii
-anat_follower_ROI FSWe epi SUMA/tracy_WM.nii
-anat_follower_erode FSvent FSWe
-dsets In_Stim_Rest1.nii
-tcat_remove_first_trs 10
-tlrc_base MNI_caez_N27+tlrc
-align_opts_aea -ginormous_move -align_centers yes
-volreg_align_to MIN_OUTLIER
-regress_ROI_PC FSvent 3
-regress_make_corr_vols aeseg FSvent
-regress_anaticor_label FSWe
-regress_censor_motion 0.2
-regress_censor_outliers 0.1
-regress_apply_mot_types demean deriv
-regress_run_clustsim no

And the fMRI data set’s name is In_Stim_Rest1.nii.

Actually I used this script before and it worked well. But it seems something wrong this time. Thanks!


That seems okay to me. Again, it is not clear why the
input to 3dToutcount would not have a view Is that part
of what you changed? Exactly why are you modifying
the proc script?

  • rick

Hi Rick,

Thanks for the help. The changed scripts work well actually.
I just found that 3dToutcount can not open the dataset perhaps because of the shared disk I use in my computer. That disk is a shared one for double systems.
When I changed my work directory to the other places, it doesn’t throw that error.

BTW, I changed the script a little bit because we found that using the original script the functional images are not centered to the anatomical image. Therefore, we add one more line to the script.

Thank you anyway Rick!


Glad you got it worked out, Tracy!

  • rick