Reconstructing functional MRI images


We are trying to reconstruct our functional MRI images using AFNI but we’re receiving the error below. The error does not occur when we try to reconstruct anatomical images.

ERROR: Failed to handle oblique (tolerance exceeded). Sorry. Stopped at /usr/local/bin/siemenstoafni line 857.

Any help would be much appreciated.

Thank you,


What is your actual command? There’s actually no command for siemenstoafni in the distribution. You probably want to use Dimon or a program like dcm2nii (part of mricron).

Hi Peter,

The command is: siemenstoafni -prefix XXX - rotobrick anat+orig ./DICOM

I have also tried toler function, but I get the same error.
siemenstoafni -toler .2 -prefix run1 -rotobrick anat+orig ./DICOM

I`ll look into Dimon.


siemenstoafni is Fred Tam’s program. The last I had heard of it was almost 10 years ago, so I can’t offer too much advice here other than to contact him (fred.tam @ ). Dimon, to3d (both in AFNI), dcm2niix (provided by Chris Rorden) and mri_convert (by Doug Greve with the FreeSurfer package) are all good alternatives.