R Installation errors while installing AFNI on Ubunbtu 16.04 TLS

Dear all,

I’ve been trying for some time now to install AFNI in the VMware player 12, running Ubuntu 16.04 TLS. I end up getting an error for installing two components of the R package, namely afex and phia.
I’ve been trying out all the suggestions that I could find on the message board:

  • I installed libcurl4-openssl-dev
  • I installed openssl and openssl-dev
  • I tried sudo apt-get install libssl-dev
  • I tried the following lines suggested by MMBB on Aug 08:
    sudo add-apt-repository -y “ppa:marutter/rrutter”
    sudo add-apt-repository -y “ppa:marutter/c2d4u”
    sudo apt-get update
    sudo apt-get install r-cran-rstan
    sudo apt-get install r-cran-shinystan
    sudo apt-get install r-cran-brms
    This fixed brms problem, but the afex and phia are still reported not installed.

I’m not familiar with linux and afni, so I don’t know how to fix this. The R installation process does report a series of errors, one of which is “internal compiler error: Killed (program cc1plus)” (see line 74 in attached terminal output file. Note: this is actually a pdf file with extension changed to .bmp to be able to upload it). This results in compilation failure for package ‘readr’.
I would very much appreciate some advice on how to solve this problem.
Many thanks in advance.


Terminal output file AFNI installation error.bmp (127 KB)

Hi, Peter-

Could you please attach the output of:

afni_system_check.py -check_all

? (that way we can see your version of R, AFNI, and some other packages.)

Note that you can try installing a package in R directly with (First type “R” on the command line, to enter the R environment):


That might be something to try, too.