problems with

I am trying to use on the FT_analysis, as specified in the “AFNI start to finish” powerpoint guide.

When I use the “” command it tells me that it failed to import PyQt4.QtGui. When I follow the directions (B1) in the -help_install, it tells me “no package found for specification ‘pyqt4-py27’”. I have tried manually installing fink and pyqt, but that didn’t work either. Python2.7 is set to my path, because I can open it without any problems.

Can someone help me get to run?


Hi Nick,

That help needs to be updated. Are you on a mac, and
are you using homebrew? If so, try:

brew install pyqt

If you have any trouble, please send me email (click on
my name) with the output from: -check_all
  • rick

The problem was that I had to add PyQt to my PYTHONPATH, as specified in the output of -check_all.

Thank you for your help!


I am using the data from subject FT provided for tutorial usage, so I don’t think that is the problem.

It works fine when I use the proc.FT generated by the “s01.ap.simple”, but when I try to generate my own proc.FT using uber_subject it starts not generating the xmatrix or stats files. I have tried setting the uber_subject parameters to exactly what is specified in the “AFNI start to finish” powerpoint tutorial. And I also checked the generated proc.FT script to make sure that the -fout -tout -x1D and -bucket stats.$subj are all there.

Looking through the terminal output I see the following error message:

dyld: Library not loaded: /usr/local/lib/libgomp.1.dylib
Referenced from: /Users/Shared/abin/3dAllineate
Reason: image not found
#**ERROR Could not square a circle (3dAllineate could not align anat to epi)
Traceback (most recent call last):
File “/Users/Shared/abin/”, line 3169, in
ps.align_anat2epi(e, a, ps.epi_wt, ps.AlOpt, suff, mcost)
TypeError: ‘NoneType’ object is not iterable

So it seems that it is encountering something and ending prematurely, but it generates a results folder and tells me that it was a success.

Any idea of what is going on? Also relevant - I am running only epi_r1 and have modified the corresponding timing .txt files so that they only contain the first run.


Hi Nick,

Would you please provide that output?


  • rick

-------------------------------- general ---------------------------------
architecture: 64bit
system: Darwin
release: 15.4.0
version: Darwin Kernel Version 15.4.0: Fri Feb 26 22:08:05 PST 2016; root:xnu-3248.40.184~3/RELEASE_X86_64
distribution: 10.11.4 x86_64
number of CPUs: 4
apparent login shell: tcsh

--------------------- AFNI and related program tests ---------------------
which afni : /Users/Shared/abin/afni
afni version : Precompiled binary macosx_10.7_Intel_64: Dec 10 2014
which python : /usr/bin/python
python version : 2.7.10
which R :
which tcsh : /bin/tcsh

instances of various programs found in PATH:
afni : 1 (/Users/Shared/abin/afni)
R : 0
python : 1 (/usr/bin/python)

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : success : success
3dAllineate : FAILURE
dyld: Library not loaded: /usr/local/lib/libgomp.1.dylib
Referenced from: /Users/Shared/abin/3dAllineate
Reason: image not found
3dRSFC : success
SurfMesh : success

checking for $HOME files…
.afnirc : missing
.sumarc : missing
.afni/help/all_progs.COMP : missing

------------------------------ python libs -------------------------------
++ module ‘PyQt4’ found at /usr/local/lib/python2.7/site-packages/PyQt4
++ module loaded: PyQt4

------------------------------- path vars --------------------------------
PATH = /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Users/Shared/abin:/Users/Nick/bin:.

PYTHONPATH = /usr/local/lib/python2.7/site-packages/


------------------------------ data checks -------------------------------
data dir : found AFNI_data6 under $HOME/work/PSYC571
top history: 16 Oct 2015 [rickr]: added FT_analysis/PPI directory, with PPI scripts
data dir : missing suma_demo
atlas : found TT_N27+tlrc under /Users/Shared/abin

------------------------------ OS specific -------------------------------

---------------------------- general comments ----------------------------

  • consider copying AFNI.afnirc to ~/.afnirc
  • consider running “suma -update_env” for .sumarc