Problem with -resid option in 3dMVM


I have an issue with the -resid option running 3dMVM program. Here’s my script:

3dMVM -prefix VBM_WM_corr.nii -jobs 8
-bsVars “ME*Sex+Age+TIV”
-qVars “ME,Age,TIV”
-qVarCenters ‘21.94,24.16,1376.64’
-mask “mask.nii”
-resid “WM_6mm_corr_resid.nii”
The rest is the data table structure itself so I’ll just skip it, it’s intact because the program runs freely without the -resid option.

When I run the script, here’s what the terminal shows:
** Error:
Expecting 1 parameters for option “-mask”.
Have 3 parameter(s) in string “mask.nii -resid WM_6mm_corr_resid.nii” instead.
NOTE that -resid in bad option above is not a recognized option.

** Error:
Error parsing arguments. See 3dMVM -help for details.

Does anyone happen to have a clue what could be wrong?

I appreciate the help in advance,

Michal, what is your AFNI version?

afni -ver

The currently installed AFNI version is 18.1.33.

Update your AFNI, and see if the script works as expected:

@update.afni.binaries -d

Thanks a lot! It solved the problem.