prefix path issue on 3dttest++ during Clustsim (Version AFNI_20.0.24 'Galba')

Hi, I had recently updated my AFNI version and start having an issue with Clustsim.
So hope to ask your help to solve this issue.

When I run a simple command as below for one-sample t-test

3dttest++ -prefix …/Results/output.nii.gz -setA … -resid …/Results/resid.nii.gz -ACF -Clustsim

Everything goes smoothly until the end when 3dttest++ uses 3drefit to add Clustsim table into file header.
The error message showed as below.

++ 3drefit: AFNI version=AFNI_20.0.24 (Mar 31 2020) [64-bit]
++ Authored by: RW Cox
++ Processing AFNI dataset …/Results/output.nii.gz
+ atrcopy
++ applying attributes
+ loading and re-writing dataset …/Results/output.nii.gz (…/Results/…/Results/output.nii.gz in NIFTI storage)
** ERROR (nifti_image_read): failed to find header file for ‘…/Results/…/Results/output.nii.gz’
++ 3drefit processed 1 datasets
++ 3dttest++ ----- Cleaning up intermediate files:
+ 3dttest++ =============== -Clustsim work is finished :slight_smile: ===============
++ ----- 3dttest++ says so long, farewell, and happy trails to you :slight_smile: -----

It seems the dir path of prefix added prefix again while processing 3drefit, and looks like a bug.
I can use the data since I have all table, but because I’m currently developing a pipeline framework that organizing data with a certain structure for each step (based on BIDS), and this error breaks the pipeline. so I really hope that this issue could be resolved and look forward to your comment!

Thank you!


Hmmm. I just tried a similar command on my system and it worked.

I just now made some changes to the way NIFTI filenames are processed/stored inside the dataset structure. This will change the way the filename appear in messages like you got, but shouldn’t affect the operation in any other way. (I replace the filename given on the command line with its “realpath” - the actual filepath starting at “/”.)

I’ll check those in, but I don’t think this can fix a problem that I can’t duplicate here.

The issues have resolved after updating to AFNI 20.1.07 ‘Otho’
Not sure why it was not duplicated, I’m expecting it may have only happened for the version I used? (installed around March 27, at Centos 7)

Anyway, Thank you for resolving the issue so quickly! It is working smoothly now!
I hope you all stay safe and healthy!