Potential Bug in @chauffeur_afni

Hey everyone,

I was playing around with @chauffeur_afni to create images and I noticed that for axial and coronal views in montages, the image is flipped such that left = right. I confirmed this by manually loading the dataset into AFNI and checking it out using the normal viewing windows. Attached are 2 images. The first is the montage output from @chauffeur_afni where I want you to focus on the pattern of activation in the last image on the bottom right. Then, the next image is a screenshot from AFNI showing clearly that the image in the @chauffeur_afni montage matches this left = right view. What’s weird is that this problem occurs in the axial and coronal views output from @chauffeur_afni but the sagittal view is fine (i.e., left = left for that one).

Finally, here is my @chauffeur_afni code whereby I specify that left should be left:



# Finally, create montage for correlation images

# Set top directory and go to it
set topdir_corr =  /mnt/c/Users/brrobert/OneDriveUW/Desktop/fMRIdata/Correlation_Files

cd topdir_corr


# Set contrast label and brick numbers
set contrast_label = DW
set mean_brick_number = 4
set tstat_brick_number = 5
set min_cluster = 20


# Create new results output directory to store all of the correlation results in
set outputdir = ${topdir_corr}/${contrast_label}_Correlation_Images
if ( ! -d $outputdir ) mkdir $outputdir

# Create overlay montage image sets for this contrast
    @chauffeur_afni                                                 \
        -ulay               TT_N27+tlrc                             \
        -olay               Correlations_DW+tlrc            \
        -cbar               Reds_and_Blues_Inv                      \
        -pbar_saveim        ${outputdir}/Reds_and_Blues_Inv_Colour_Bar.jpg \
        -pbar_dim 128x1022 \
        -clusterize         "-NN 2 -bisided p=0.001 -clust_nvox ${min_cluster} -orient LPI" \
        -set_subbricks      -1 "SpmnCorr#0" "SpmnCorr#0" \
        -thr_olay_p2stat    0.01                                   \
        -thr_olay_pside     bisided                                 \
        -olay_alpha         Yes                                     \
        -olay_boxed         Yes                                     \
        -opacity            9                                       \
        -prefix             ${outputdir}/${contrast_label}_Clust_Montage2  \
        -montx 5 -monty 2 -montgap 0                                \
        -set_xhairs OFF                                             \
        -label_mode 1 -label_size 4 -label_color white -label_setback 0.01 -label_string ""                                 \
        -box_focus_slices group_mask_.7olap+tlrc.                   \
        -save_ftype PNG                                            \
        -blowup 4                                                   \
        -left_is_left LIL                                           \
        -do_clean

Hi, Brady-

So, the option to use to specify “left is left” should look like:


-left_is_left YES

The “-left_is_left LIL” in the help file is using LIL as a placeholder for either YES or NO. Please let me know if changing “LIL” to “YES” fixes your issue.

(For me, “-left_is_left LIL” behaved like “-left_is_left NO”—but I will make the code give an error if neither YES nor NO is provided as the option argument.)

And yes, the “left_is_left” value applies to both axial and coronal.

Re. sagittal images: “-left_is_posterior …” is a separate option to control that.

–pt

Hi Paul,

…aaaaaaand yep, setting ‘-left_is_left YES’ fixed my problem. Well, now I feel silly. Apologies for the false alarm.

  • Brady

No worries at all—better to ask (and always glad to see when people are doublechecking that what a program outputs matches their expectation).

Glad that sorted it.

–pt