Library not loaded error

I get this error when running my group’s fMRI processing pipeline:

3ddot -dodice full_mask.p249+orig mask_anat.p249+orig
tee out.mask_ae_dice.txt
dyld: Library not loaded: /sw/lib/libjpeg.9.dylib
  Referenced from: /Users/witherscp/abin/3ddot
  Reason: image not found

When I run “ -check_all”, this is my output:

-------------------------------- general ---------------------------------
architecture:         64bit 
system:               Darwin
release:              19.6.0
version:              Darwin Kernel Version 19.6.0: Mon Apr 18 21:50:40 PDT 2022; root:xnu-6153.141.62~1/RELEASE_X86_64
distribution:         10.15.7
number of CPUs:       16
apparent login shell: bash
shell RC file:        .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni           : /Users/witherscp/abin/afni
afni version         : Precompiled binary macos_10.12_local: Jun 24 2022 
                     : AFNI_22.1.14 'Antoninus Pius'
AFNI_version.txt     : AFNI_22.1.14, macos_10.12_local, Jun 24 2022
which python         : /Users/witherscp/anaconda3/bin/python
python version       : 3.8.12
which R              : /usr/local/bin/R
R version            : R version 3.6.3 (2020-02-29) -- "Holding the Windsock"
which tcsh           : /bin/tcsh

instances of various programs found in PATH:
    afni    : 1   (/Users/witherscp/abin/afni)
    R       : 1   (/Library/Frameworks/R.framework/Versions/3.6/Resources/bin/R)
    python  : 2 
    python2 : 1   (/System/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7)
    python3 : 2 

testing ability to start various programs...
    afni                 : success
    suma                 : success
    3dSkullStrip         : success      : success
    3dAllineate          : success
    3dRSFC               : success
    SurfMesh             : success
    3dClustSim           : success
    3dMVM                : success

checking for R packages...
    rPkgsInstall -pkgs ALL -check : success

R RHOME : /Library/Frameworks/R.framework/Resources

checking for $HOME files...
    .afnirc                   : found
    .sumarc                   : found
    .afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** failed to load module PyQt4
-- PyQt4 is no longer needed for an AFNI bootcamp

++ module loaded: matplotlib.pyplot
   module file : /Users/witherscp/anaconda3/lib/python3.8/site-packages/matplotlib/
   matplotlib version : 3.3.4

-------------------------------- env vars --------------------------------
PATH = /opt/local/bin:/opt/local/sbin:/Users/witherscp/anaconda3/bin:/Users/witherscp/anaconda3/condabin:/Users/witherscp/TORTOISE_V3.2.0/DRTAMASV320/bin:/Users/witherscp/TORTOISE_V3.2.0/DRBUDDIV320/bin:/Users/witherscp/TORTOISE_V3.2.0/DIFFCALC/DIFFCALCV320:/Users/witherscp/TORTOISE_V3.2.0/DIFFPREPV320/bin/bin:/Applications/freesurfer/bin:/Applications/freesurfer/fsfast/bin:/Applications/freesurfer/tktools:/usr/local/fsl/bin:/Applications/freesurfer/mni/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/opt/X11/bin:/Users/witherscp/abin:/Applications/

PYTHONPATH = :/Volumes/shares/NEU/Users/price

DYLD_LIBRARY_PATH = /Applications/freesurfer/lib/gcc/lib::/opt/X11/lib/flat_namespace:/Users/witherscp/TORTOISE_V3.2.0/DRBUDDIV320/bin


------------------------------ data checks -------------------------------
data dir : found AFNI_data6   under $HOME (954004M Avail)
           top history: 20 Feb 2020 [rickr]: updated FT_analysis examples
data dir : found AFNI_demos   under $HOME
           top history: ...ct 2020 [taylorp]: updated scripts under FATCAT_DEMO
data dir : found suma_demo    under $HOME
           top history: ...s_New/data/Build_tmp on Mon Mar  4 11:56:45 EST 2013
data dir : found afni_handouts under $HOME
atlas    : found TT_N27+tlrc  under /Users/witherscp/abin

------------------------------ OS specific -------------------------------
XQuartz version      : 2.8.1

which brew           : /usr/local/bin/brew
brew version         : Homebrew 2.1.16
which port           : /opt/local/bin/port
port version         : Version: 2.7.2

-- for PyQt4 under brew, consider running:
   brew install cartr/qt4/pyqt
-- consider installing gcc under homebrew
** consider linking /usr/local/Cellar/glib/2.58.3/lib/libglib-2.0.dylib under /usr/local/lib
++ found 1 dylib files under '/opt/X11/lib/flat_namespace'
   -- found 'libXt' dylib files:
++ yay, env var DYLD_LIBRARY_PATH contains /opt/X11/lib/flat_namespace

=========================  summary, please fix:  =========================
*  just be aware: login shell 'bash', but our code examples use 'tcsh'

I have never encountered this problem before. Do you know how to fix this?


Sorry for being slow, it was a while before getting around to debugging this.

It looks like 3ddot just happens to not like how linking is altered to be local. It just seems to be that one program in the entire distribution that fails.

I will fix this an run an updated build.

Thanks a lot for bringing it up!

  • rick

The fix for this went in and should be built and distributed to the afni server. So please feel free to update your binaries and see if it works again.


  • rick

The fix worked! Thanks for your help.

Great, thanks for the update!

  • rick