lib error in Mac OS 10.11

Dear Experts,

     I have got an error message on the library setting after installing AFNI in the Mac OS 10.11.
     dyld: Library not loaded: /usr/local/lib/libgomp.1.dylib
     It comes from the command 3dAllineate and 3dClustsim.

     I checked previous post, and tried to set the variable of DYLD_FALLBACK_LIBRARY_PATH to AFNI's folder, but still I get the same message.
     Any help will be appreciated! Thanks a lot!

     Best regards,

Nan

     Below is the output of afni_system_check.py -check_all.

-------------------------------- general ---------------------------------
architecture: 64bit
system: Darwin
release: 15.6.0
version: Darwin Kernel Version 15.6.0: Sun Jun 4 21:43:07 PDT 2017; root:xnu-3248.70.3~1/RELEASE_X86_64
distribution: 10.11.6 x86_64
number of CPUs: 24
apparent login shell: bash
shell RC file: .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /Applications/AFNI_ox64/afni
afni version : Precompiled binary macosx_10.7_Intel_64: Oct 12 2017
: AFNI_17.3.00
AFNI_version.txt : AFNI_17.3.00, macosx_10.7_Intel_64, Oct 12 2017
which python : /sw/bin/python
python version : 2.7.14
which R : /usr/local/bin/R
R version : R version 3.4.2 (2017-09-28) – “Short Summer”
which tcsh : /bin/tcsh

instances of various programs found in PATH:
afni : 1 (/Applications/AFNI_ox64/afni)
R : 1 (/Library/Frameworks/R.framework/Versions/3.4/Resources/bin/R)
python : 2
/sw/bin/python2.7
/usr/bin/python
python2 : 0
python3 : 0

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : success
uber_subject.py : success
3dAllineate : FAILURE
dyld: Library not loaded: /usr/local/lib/libgomp.1.dylib
Referenced from: /Applications/AFNI_ox64/3dAllineate
Reason: image not found
3dRSFC : success
SurfMesh : success
3dClustSim : FAILURE
dyld: Library not loaded: /usr/local/lib/libgomp.1.dylib
Referenced from: /Applications/AFNI_ox64/3dClustSim
Reason: image not found

checking for R packages…
rPkgsInstall -pkgs ALL -check : success

checking for $HOME files…
.afnirc : found
.sumarc : found
.afni/help/all_progs.COMP : missing

------------------------------ python libs -------------------------------
++ module ‘PyQt4’ found at /sw/lib/qt4-mac/lib/python2.7/site-packages/PyQt4
++ module loaded: PyQt4

python binaries under /sw/bin:
/sw/bin/python (sym link to /sw/bin/python2.7)
/sw/bin/python2.7

-------------------------------- env vars --------------------------------
PATH = /sw/bin:/sw/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/Applications/AFNI_ox64:/Applications/fsl/bin:/Applications/freesurfer/bin:/Applications/MATLAB_R2013b.app/bin

PYTHONPATH = /sw/lib/qt4-mac/lib/python2.7/site-packages

R_LIBS =
LD_LIBRARY_PATH =
DYLD_LIBRARY_PATH (sub-shell) = /opt/X11/lib/flat_namespace
DYLD_FALLBACK_LIBRARY_PATH (sub-shell) = /Applications/AFNI_ox64

------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /Applications/AFNI_ox64

------------------------------ OS specific -------------------------------
which fink : /sw/bin/fink
fink version : Package manager version: 0.42.0

++ found 1 dylib files under ‘/opt/X11/lib/flat_namespace’
– found ‘libXt’ dylib files:
/opt/X11/lib/flat_namespace/libXt.6.dylib
– recent OS X, cheating to check DYLD_LIBRARY_PATH in cur shell ‘bash’…
++ found evar DYLD_LIBRARY_PATH = /opt/X11/lib/flat_namespace
– recent OS X, cheating to check DYLD_LIBRARY_PATH in shell ‘tcsh’…
** env var DYLD_LIBRARY_PATH not set to contain /opt/X11/lib/flat_namespace

========================= summary, please fix: =========================

  • login shell ‘bash’, trusting user to translate from ‘tcsh’
  • shell bash: consider sourcing (non-login) .bashrc from (login) .profile
  • AFNI programs show FAILURE
  • consider running: apsearch -update_all_afni_help
  • insufficient data for AFNI bootcamp
  • please set DYLD_LIBRARY_PATH to /opt/X11/lib/flat_namespace in tcsh

Hi Nan,

If you use the 10.7_local package instead, it is not
necessary to set up those extra libraries.

@update.afni.binaries -package macosx_10.7_local

  • rick

Thanks a lot Rick! It works now.

So what’s the difference in the binary package between the intel version and local version? I downloaded and installed the intel version from the afni website previously.

Nan

It is just a different build setup, specifically to make it
easier to deal with those libraries. It is even done on
the same machine as the Intel_64 package.

  • rick

Thanks Rick!