Keeping output in 'short' format with

Dear AFNI team,

We are using to preprocess our fMRI data and it seems to be working pretty well. However, starting from the 3dNwarpApply step in the -blip block, the output changes from short datum format to float format, and we would like to keep everything in short format to save disk space. One option would be to edit the shell script created by for each subject to add the ‘-short’ tag to the 3dNwarpApply command before running it, but we were wondering if it is possible to set that option in the command itself. Any suggestions would be appreciated!

Thank you,

Leo Fernandino

Hi Leo,

Sorry for being slow to reply, though I have pondered this a little.

How big are the numbers coming out of 3dNwarpApply, in the thousands?

If so, I added an option for you to specify “-short” to the 3dNwarpApply commands (it would apply to all of the EPI warping calls).

-volreg_opts_ewarp -short

I added that Nov 29, but forgot to let you know, sorry!

Note that this won’t produce scaled shorts. If you want that, we could ponder ways to do it in the blur (needs a change) or scale (easy) steps.

  • rick