installation on mac os 10.12.6

Hi everybody,

I’m trying to install AFNI for the first time in a very long time on my mac running 10.12.6. Looking in https://afni.nimh.nih.gov/pub/dist/tgz/ I see that there are several different binaries for MAC. I’ve downloaded (yesterday sept 27, 2017) the macos_10.12_local.tgz tarball and unpacked it. When I run afni -ver I get

When I try to tun it I get:


colmconn@Colms-MacBook-Pro:~/afni.macosx_10_12> ./afni -ver
Precompiled binary macos_10.12_local: Sep 19 2017 (Version AFNI_17.2.16)
colmconn@Colms-MacBook-Pro:~/afni.macosx_10_12> ./afni
Precompiled binary macos_10.12_local: Sep 19 2017 (Version AFNI_17.2.16)

Thanks go to D Handwerker for useful feedback

Initializing: X11
++ If you are using XQuartz 2.7.10 (or later), and AFNI crashes when
 + opening windows, or you cannot type text into AFNI popup windows,
 + you might need to set an environment variable to solve this problem:
 +   setenv DYLD_LIBRARY_PATH /opt/X11/lib/flat_namespace
 + This command is best put in your startup ~/.cshrc file, so that
 + it will be invoked for every (t)csh shell you open.

[The X.Org Foundation v 11804000].dyld: Library not loaded: /usr/local/lib/libgcc_s.1.dylib
  Referenced from: /Users/colmconn/afni/djpeg
  Reason: image not found
dyld: Library not loaded: /usr/local/lib/libgcc_s.1.dylib
  Referenced from: /Users/colmconn/afni/djpeg
  Reason: image not found

Fatal Signal 11 (SIGSEGV) received
       ISQ_record_button
      open_MCW_imseq
     SPLASH_popup_image
    AFNI_splashup
   MAIN_workprocess
  AFNI:main
 Bottom of Debug Stack
** AFNI version = AFNI_17.2.16  Compile date = Sep 19 2017
** [[Precompiled binary macos_10.12_local: Sep 19 2017]]
** Program Death **
** If you report this crash to the AFNI message board,
** please copy the error messages EXACTLY, and give
** the command line you used to run the program, and
** any other information needed to repeat the problem.
** You may later be asked to upload data to help debug.
** Crash log is appended to file /Users/colmconn/.afni.crashlog
++ AFNI is detached from terminal.
colmconn@Colms-MacBook-Pro:~/afni.macosx_10_12> 

Am I using the wrong tarball? If so which one should I be using?

Also going through the list of mac binaries on the download site, the timestamps do not reflect the latest build date at https://afni.nimh.nih.gov Is there something up with the mac build infrastructure?

Thanks for you help.

Are you using 10.12 via an upgrade (rather than a new system)?

Maybe your Xcode is old. In any case, the 10.7 package should
work if you want to use that:

@update.afni.binaries -defaults -package macosx_10.7_local
  • rick

Hi,
If you want to start over, you can try:
https://afni.nimh.nih.gov/afni/community/board/read.php?1,156123,156123#msg-156123
Good luck, Justin