Faltung command

Dear AFNI experts,

I am running a PPI analysis, but when I run the following command:

3dTfitter -RHS seed_BOLD.1D -FALTUNG GAM.1D seed_neuro.1D 012 0 \

the output file seed_neuro.1D is actually a 3D file, with the following structure:


self_idcode = …

ni_type = “456*float”


This is quite strange, since the same scripts worked for my colleagues in my lab.
I have checked my input 1D file, and they seem legit.
My afni version is 19.1.12

Any idea on why and how to fix this issue?


Hi Giono,

That is typical behavior. It is more surprising that your colleagues would be getting something different.

I expect the next line of the file (after ni_type = “456*float”) reads (# ni_dimen = “1,1,1”), meaning the 3D aspect of the file is actually 1x1x1, making it a single voxel, 456 time point dataset.

Are you having trouble working with the file?

  • rick

Hi Rick,


Yes, I do have problems to work with it, since next command is:

1deval -a seed_neuro.1D -b GAM.1d -expr ‘a*b’

where a is the output of the FALTUNG and this produces an output that is a file with a unique 0 instead of 456 values.

Run 1dtranspose after 3dTfitter.

Consider the sample analysis under AFNI_data6/FT_analysis/PPI.
Those commands are in cmd.ppi.2.make.regs (search for 3dTfitter).

Just let me know if you run into any more difficulties.

  • rick

This worked fine! Thank you!