Error When Opening AFNI

Hi everyone,

I just installed AFNI and trying to open the program, but it keeps crashing. I tried the suggestion they had to set the environment variable, but that did not work. I am pasting the terminal output below and would appreciate any suggestion you have to fix this issue. Thank you!


Initializing: X11
++ If you are using XQuartz 2.7.10 (or later), and AFNI crashes when

  • opening windows, or you cannot type text into AFNI popup windows,
  • you might need to set an environment variable to solve this problem:
  • setenv DYLD_LIBRARY_PATH /opt/X11/lib/flat_namespace
  • This command is best put in your startup ~/.cshrc file, so that
  • it will be invoked for every (t)csh shell you open.

++ AFNI is detached from terminal.
nis-114-9:~ bdirks$ [The X.Org Foundation v 11804000].
Fatal Signal 11 (SIGSEGV) received
Bottom of Debug Stack
** AFNI version = AFNI_19.2.23 Compile date = Sep 6 2019
** [[Precompiled binary macos_10.12_local: Sep 6 2019]]
** Program Death **
** If you report this crash to the AFNI message board,
** please copy the error messages EXACTLY, and give
** the command line you used to run the program, and
** any other information needed to repeat the problem.
** You may later be asked to upload data to help debug.
** Crash log is appended to file /Users/bdirks/.afni.crashlog


What is the output of the following (please copy+paste each into your terminal, and copy+paste the output returned by each, or state “NONE”):

echo $0


grep -H bashrc ~/.bash_profile

mdls -name kMDItemVersion /Applications/Utilities/


  1. nis-114-9:~ bdirks$ echo $0

  2. NONE

  3. NONE

  4. nis-114-9:~ bdirks$ mdls -name kMDItemVersion /Applications/Utilities/
    kMDItemVersion = “2.7.11”


OK, I think the thing happening is that the $DYLD_LIBRARY_PATH variable is set in your ~/.bashrc file correctly (from following the setup instructions), but that that file is not getting sourced (or read) when starting up the terminal; you can instruct the ~/.bash_profile overlord file to do that by copy+pasting the following into your terminal:

echo "" >> ~/.bash_profile
echo "source ~/.bashrc" >> ~/.bash_profile
echo "" >> ~/.bash_profile

Then, please open a new terminal, and see if “afni” and “suma” work (both should). Every new terminal should be good to go now.


That worked, thank you!