error in installing AFNI on Ubuntu 20.04

Hello

I’m running ubuntu 20.04.
I followed the instruction on your web site.
But when I get to the step:
rPkgsInstall -pkgs ALL
There were many error messages.

The output to
afni_system_check.py -check_all
is:

-------------------------------- general ---------------------------------
architecture: 64bit
system: Linux
release: 5.4.0-48-generic
version: #52-Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020
distribution: Ubuntu 20.04 focal
number of CPUs: 18
apparent login shell: bash
shell RC file: .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /home/cslaw/abin/afni
afni version : Precompiled binary linux_ubuntu_16_64: Oct 2 2020
: AFNI_20.3.00 ‘Vespasian’
AFNI_version.txt : AFNI_20.3.00, linux_ubuntu_16_64, Oct 02 2020
which python : /usr/bin/python
python version : 2.7.18rc1
which R : /usr/bin/R
R version : R version 4.0.2 (2020-06-22) – “Taking Off Again”
which tcsh : /usr/bin/tcsh

instances of various programs found in PATH:
afni : 1 (/home/cslaw/abin/afni)
R : 1 (/usr/bin/R)
python : 1 (/usr/bin/python2.7)
python2 : 1 (/usr/bin/python2.7)
python3 : 1 (/usr/bin/python3.8)

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : FAILURE
3dSkullStrip: error while loading shared libraries: libgsl.so.19: cannot open shared object file: No such file or directory
uber_subject.py : success
3dAllineate : success
3dRSFC : FAILURE
3dRSFC: error while loading shared libraries: libgsl.so.19: cannot open shared object file: No such file or directory
SurfMesh : success
3dClustSim : success
3dMVM : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : FAILURE

    oo Warning: 
       These packages are not installed on the computer: afex!
    These packages are not installed on the computer: phia!
    These packages are not installed on the computer: lmerTest!
    These packages are not installed on the computer: brms!

R RHOME : /usr/lib/R

checking for $HOME files…
.afnirc : found
.sumarc : found
.afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** failed to load module PyQt4
– PyQt4 is no longer needed for an AFNI bootcamp

** failed to load module matplotlib.pyplot
– matplotlib.pyplot is not required, but is desirable

-------------------------------- env vars --------------------------------
PATH = /home/cslaw/sct_4.3/bin:/home/cslaw/sct_4.3/bin:/home/cslaw/sct_4.3/bin:/usr/local/fsl/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/cslaw/abin:/home/cslaw/abin:/home/cslaw/abin

PYTHONPATH =
R_LIBS = /home/cslaw/R

LD_LIBRARY_PATH =
DYLD_LIBRARY_PATH =
DYLD_FALLBACK_LIBRARY_PATH =

------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /home/cslaw/abin

------------------------------ OS specific -------------------------------
which apt-get : /usr/bin/apt-get
apt-get version : apt 2.0.2ubuntu0.1 (amd64)

have Ubuntu system: Ubuntu 20.04 focal
have Ubuntu afni : Precompiled binary linux_ubuntu_16_64: Oct 2 2020

========================= summary, please fix: =========================

  • just be aware: login shell ‘bash’, but our code examples use ‘tcsh’
  • AFNI programs show FAILURE
  • missing R packages (see rPkgsInstall)
  • insufficient data for AFNI bootcamp

Could you please help?
Christine

Hi, Christine-

Thanks for posting the system check output.

One thing to note-- unrelated to the R stuff-- is this pair of error messages:


3dSkullStrip : FAILURE
3dSkullStrip: error while loading shared libraries: libgsl.so.19: cannot open shared object file: No such file or directory
3dRSFC : FAILURE
3dRSFC: error while loading shared libraries: libgsl.so.19: cannot open shared object file: No such file or directory

I think that reflects that one small step in installation was missed. Could you please copy+paste this into a terminal:


sudo ln -s /usr/lib/x86_64-linux-gnu/libgsl.so.23 /usr/lib/x86_64-linux-gnu/libgsl.so.19

… which will ask you for your admin/root password. Could you then open a new terminal, run the system check again, and verify that the above errors are gone?

Re. the R package installation errors: sigh, R has been a bit of a pain… I notice that you have R versions 4.0. At the moment, AFNI requires 3.6.*, and I though that the latter was the version of R installed by Ubuntu 20.04’s package manager (Aptitude). Is the version of R that you have just from the initial big command here:
https://afni.nimh.nih.gov/pub/dist/doc/htmldoc/background_install/install_instructs/steps_linux_ubuntu20.html#install-prerequisite-packages
… or through some other installation means?

–pt

Dear pt

I indeed ran the command
sudo ln -s /usr/lib/x86_64-linux-gnu/libgsl.so.23 /usr/lib/x86_64-linux-gnu/libgsl.so.19

It returns
ln: failed to create symbolic link ‘/usr/lib/x86_64-linux-gnu/libgsl.so.19’: File exists

System check still returns errors on 3dSkullStrip and 3dRSFC. (please see below)

BTW, I had to execute
sudo apt-get install libglu1
because I got an error
libGLU.so.1: cannot open shared object file: No such file or directory

Back to the R related error:
I down graded to R 3.6 but I still got many errors/warnings after executing rPkgsInstall -pkgs ALL
(please see below under ***** R related issues ******* )

Please let me know if you know how to fix my problems.
thanks
Christine

cslaw@mackeylab1027:~$ afni_system_check.py -check_all
-------------------------------- general ---------------------------------
architecture: 64bit
system: Linux
release: 5.4.0-48-generic
version: #52-Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020
distribution: Ubuntu 20.04 focal
number of CPUs: 18
apparent login shell: bash
shell RC file: .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /home/cslaw/abin/afni
afni version : Precompiled binary linux_ubuntu_16_64: Oct 2 2020
: AFNI_20.3.00 ‘Vespasian’
AFNI_version.txt : AFNI_20.3.00, linux_ubuntu_16_64, Oct 02 2020
which python : /usr/bin/python
python version : 2.7.18rc1
which R : /usr/bin/R
R version : R version 3.6.3 (2020-02-29) – “Holding the Windsock”
which tcsh : /usr/bin/tcsh

instances of various programs found in PATH:
afni : 1 (/home/cslaw/abin/afni)
R : 1 (/usr/bin/R)
python : 1 (/usr/bin/python2.7)
python2 : 1 (/usr/bin/python2.7)
python3 : 1 (/usr/bin/python3.8)

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : FAILURE
3dSkullStrip: error while loading shared libraries: libgsl.so.19: cannot open shared object file: No such file or directory
uber_subject.py : success
3dAllineate : success
3dRSFC : FAILURE
3dRSFC: error while loading shared libraries: libgsl.so.19: cannot open shared object file: No such file or directory
SurfMesh : success
3dClustSim : success
3dMVM : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : FAILURE

    oo Warning: 
       These packages are not installed on the computer: afex!
    These packages are not installed on the computer: phia!
    These packages are not installed on the computer: lmerTest!
    These packages are not installed on the computer: brms!

R RHOME : /usr/lib/R

checking for $HOME files…
.afnirc : found
.sumarc : found
.afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** failed to load module PyQt4
– PyQt4 is no longer needed for an AFNI bootcamp

** failed to load module matplotlib.pyplot
– matplotlib.pyplot is not required, but is desirable

-------------------------------- env vars --------------------------------
PATH = /home/cslaw/sct_4.3/bin:/usr/local/fsl/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/cslaw/abin:/home/cslaw/Documents/MATLAB/fmriutil

PYTHONPATH =
R_LIBS = /home/cslaw/R

LD_LIBRARY_PATH =
DYLD_LIBRARY_PATH =
DYLD_FALLBACK_LIBRARY_PATH =

------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /home/cslaw/abin

------------------------------ OS specific -------------------------------
which apt-get : /usr/bin/apt-get
apt-get version : apt 2.0.2ubuntu0.1 (amd64)

have Ubuntu system: Ubuntu 20.04 focal
have Ubuntu afni : Precompiled binary linux_ubuntu_16_64: Oct 2 2020

========================= summary, please fix: =========================

  • just be aware: login shell ‘bash’, but our code examples use ‘tcsh’
  • AFNI programs show FAILURE
  • missing R packages (see rPkgsInstall)
  • insufficient data for AFNI bootcamp

****************************** R related issues ****************************************
cslaw@mackeylab1027:~$ rPkgsInstall -pkgs ALL
Installing packages into ‘/home/cslaw/R’
(as ‘lib’ is unspecified)
Warning: dependencies ‘cmdstanr’, ‘foreign’ are not available
also installing the dependencies ‘conquer’, ‘data.table’, ‘httr’, ‘hexbin’, ‘robustbase’, ‘openssl’, ‘igraph’, ‘units’, ‘cluster’, ‘RcppEigen’, ‘quantreg’, ‘rio’, ‘survival’, ‘libcoin’, ‘jpeg’, ‘psych’, ‘rstatix’, ‘TMB’, ‘StanHeaders’, ‘plotly’, ‘qqplotr’, ‘V8’, ‘rsconnect’, ‘threejs’, ‘msm’, ‘gsl’, ‘sf’, ‘expm’, ‘tmvnsim’, ‘RcppArmadillo’, ‘Hmisc’, ‘lme4’, ‘pbkrtest’, ‘car’, ‘coin’, ‘latticeExtra’, ‘mlmRev’, ‘Matrix’, ‘psychTools’, ‘MEMSS’, ‘effects’, ‘ggpubr’, ‘glmmTMB’, ‘rstanarm’, ‘ggResidpanel’, ‘rstan’, ‘mgcv’, ‘shinystan’, ‘nleqslv’, ‘rtdists’, ‘spdep’, ‘mnormt’, ‘MCMCglmm’, ‘splines2’, ‘ape’, ‘arm’

trying URL ‘http://cloud.r-project.org/src/contrib/conquer_1.0.2.tar.gz
Content type ‘application/x-gzip’ length 12322 bytes (12 KB)

downloaded 12 KB

trying URL ‘http://cloud.r-project.org/src/contrib/data.table_1.13.0.tar.gz
Content type ‘application/x-gzip’ length 5273400 bytes (5.0 MB)

downloaded 5.0 MB

trying URL ‘http://cloud.r-project.org/src/contrib/httr_1.4.2.tar.gz
Content type ‘application/x-gzip’ length 159950 bytes (156 KB)

downloaded 156 KB

trying URL ‘http://cloud.r-project.org/src/contrib/hexbin_1.28.1.tar.gz
Content type ‘application/x-gzip’ length 659145 bytes (643 KB)

downloaded 643 KB

trying URL ‘http://cloud.r-project.org/src/contrib/robustbase_0.93-6.tar.gz
Content type ‘application/x-gzip’ length 2956184 bytes (2.8 MB)

downloaded 2.8 MB

trying URL ‘http://cloud.r-project.org/src/contrib/openssl_1.4.3.tar.gz
Content type ‘application/x-gzip’ length 1207708 bytes (1.2 MB)

downloaded 1.2 MB

trying URL ‘http://cloud.r-project.org/src/contrib/igraph_1.2.6.tar.gz
Content type ‘application/x-gzip’ length 2715500 bytes (2.6 MB)

downloaded 2.6 MB

trying URL ‘http://cloud.r-project.org/src/contrib/units_0.6-7.tar.gz
Content type ‘application/x-gzip’ length 957214 bytes (934 KB)

downloaded 934 KB

trying URL ‘http://cloud.r-project.org/src/contrib/cluster_2.1.0.tar.gz
Content type ‘application/x-gzip’ length 380366 bytes (371 KB)

downloaded 371 KB

trying URL ‘http://cloud.r-project.org/src/contrib/RcppEigen_0.3.3.7.0.tar.gz
Content type ‘application/x-gzip’ length 1643103 bytes (1.6 MB)

downloaded 1.6 MB

trying URL ‘http://cloud.r-project.org/src/contrib/quantreg_5.73.tar.gz
Content type ‘application/x-gzip’ length 1005353 bytes (981 KB)

downloaded 981 KB

trying URL ‘http://cloud.r-project.org/src/contrib/rio_0.5.16.tar.gz
Content type ‘application/x-gzip’ length 420489 bytes (410 KB)

downloaded 410 KB

trying URL ‘http://cloud.r-project.org/src/contrib/survival_3.2-7.tar.gz
Content type ‘application/x-gzip’ length 7657362 bytes (7.3 MB)

downloaded 7.3 MB

trying URL ‘http://cloud.r-project.org/src/contrib/libcoin_1.0-6.tar.gz
Content type ‘application/x-gzip’ length 980038 bytes (957 KB)

downloaded 957 KB

trying URL ‘http://cloud.r-project.org/src/contrib/jpeg_0.1-8.1.tar.gz
Content type ‘application/x-gzip’ length 18116 bytes (17 KB)

downloaded 17 KB

trying URL ‘http://cloud.r-project.org/src/contrib/psych_2.0.9.tar.gz
Content type ‘application/x-gzip’ length 2067299 bytes (2.0 MB)

downloaded 2.0 MB

trying URL ‘http://cloud.r-project.org/src/contrib/rstatix_0.6.0.tar.gz
Content type ‘application/x-gzip’ length 394803 bytes (385 KB)

downloaded 385 KB

trying URL ‘http://cloud.r-project.org/src/contrib/TMB_1.7.18.tar.gz
Content type ‘application/x-gzip’ length 613270 bytes (598 KB)

downloaded 598 KB

trying URL ‘http://cloud.r-project.org/src/contrib/StanHeaders_2.21.0-6.tar.gz
Content type ‘application/x-gzip’ length 1400881 bytes (1.3 MB)

downloaded 1.3 MB

trying URL ‘http://cloud.r-project.org/src/contrib/plotly_4.9.2.1.tar.gz
Content type ‘application/x-gzip’ length 3709741 bytes (3.5 MB)

downloaded 3.5 MB

trying URL ‘http://cloud.r-project.org/src/contrib/qqplotr_0.0.4.tar.gz
Content type ‘application/x-gzip’ length 1363603 bytes (1.3 MB)

downloaded 1.3 MB

trying URL ‘http://cloud.r-project.org/src/contrib/V8_3.2.0.tar.gz
Content type ‘application/x-gzip’ length 680510 bytes (664 KB)

downloaded 664 KB

trying URL ‘http://cloud.r-project.org/src/contrib/rsconnect_0.8.16.tar.gz
Content type ‘application/x-gzip’ length 379757 bytes (370 KB)

downloaded 370 KB

trying URL ‘http://cloud.r-project.org/src/contrib/threejs_0.3.3.tar.gz
Content type ‘application/x-gzip’ length 866293 bytes (845 KB)

downloaded 845 KB

trying URL ‘http://cloud.r-project.org/src/contrib/msm_1.6.8.tar.gz
Content type ‘application/x-gzip’ length 842708 bytes (822 KB)

downloaded 822 KB

trying URL ‘http://cloud.r-project.org/src/contrib/gsl_2.1-6.tar.gz
Content type ‘application/x-gzip’ length 189794 bytes (185 KB)

downloaded 185 KB

trying URL ‘http://cloud.r-project.org/src/contrib/sf_0.9-6.tar.gz
Content type ‘application/x-gzip’ length 4160758 bytes (4.0 MB)

downloaded 4.0 MB

trying URL ‘http://cloud.r-project.org/src/contrib/expm_0.999-5.tar.gz
Content type ‘application/x-gzip’ length 136730 bytes (133 KB)

downloaded 133 KB

trying URL ‘http://cloud.r-project.org/src/contrib/tmvnsim_1.0-2.tar.gz
Content type ‘application/x-gzip’ length 6052 bytes

downloaded 6052 bytes

trying URL ‘http://cloud.r-project.org/src/contrib/RcppArmadillo_0.9.900.3.0.tar.gz
Content type ‘application/x-gzip’ length 1645450 bytes (1.6 MB)

downloaded 1.6 MB

trying URL ‘http://cloud.r-project.org/src/contrib/Hmisc_4.4-1.tar.gz
Content type ‘application/x-gzip’ length 746061 bytes (728 KB)

downloaded 728 KB

trying URL ‘http://cloud.r-project.org/src/contrib/lme4_1.1-23.tar.gz
Content type ‘application/x-gzip’ length 4137774 bytes (3.9 MB)

downloaded 3.9 MB

trying URL ‘http://cloud.r-project.org/src/contrib/pbkrtest_0.4-8.6.tar.gz
Content type ‘application/x-gzip’ length 174962 bytes (170 KB)

downloaded 170 KB

trying URL ‘http://cloud.r-project.org/src/contrib/car_3.0-10.tar.gz
Content type ‘application/x-gzip’ length 501293 bytes (489 KB)

downloaded 489 KB

trying URL ‘http://cloud.r-project.org/src/contrib/coin_1.3-1.tar.gz
Content type ‘application/x-gzip’ length 1263884 bytes (1.2 MB)

downloaded 1.2 MB

trying URL ‘http://cloud.r-project.org/src/contrib/latticeExtra_0.6-29.tar.gz
Content type ‘application/x-gzip’ length 1292315 bytes (1.2 MB)

downloaded 1.2 MB

trying URL ‘http://cloud.r-project.org/src/contrib/mlmRev_1.0-8.tar.gz
Content type ‘application/x-gzip’ length 1490419 bytes (1.4 MB)

downloaded 1.4 MB

trying URL ‘http://cloud.r-project.org/src/contrib/Matrix_1.2-18.tar.gz
Content type ‘application/x-gzip’ length 1871705 bytes (1.8 MB)

downloaded 1.8 MB

trying URL ‘http://cloud.r-project.org/src/contrib/psychTools_2.0.8.tar.gz
Content type ‘application/x-gzip’ length 2670036 bytes (2.5 MB)

downloaded 2.5 MB

trying URL ‘http://cloud.r-project.org/src/contrib/MEMSS_0.9-3.tar.gz
Content type ‘application/x-gzip’ length 126951 bytes (123 KB)

downloaded 123 KB

trying URL ‘http://cloud.r-project.org/src/contrib/effects_4.2-0.tar.gz
Content type ‘application/x-gzip’ length 2256933 bytes (2.2 MB)

downloaded 2.2 MB

trying URL ‘http://cloud.r-project.org/src/contrib/ggpubr_0.4.0.tar.gz
Content type ‘application/x-gzip’ length 2689307 bytes (2.6 MB)

downloaded 2.6 MB

trying URL ‘http://cloud.r-project.org/src/contrib/glmmTMB_1.0.2.1.tar.gz
Content type ‘application/x-gzip’ length 2964506 bytes (2.8 MB)

downloaded 2.8 MB

trying URL ‘http://cloud.r-project.org/src/contrib/rstanarm_2.21.1.tar.gz
Content type ‘application/x-gzip’ length 3548723 bytes (3.4 MB)

downloaded 3.4 MB

trying URL ‘http://cloud.r-project.org/src/contrib/ggResidpanel_0.3.0.tar.gz
Content type ‘application/x-gzip’ length 1702380 bytes (1.6 MB)

downloaded 1.6 MB

trying URL ‘http://cloud.r-project.org/src/contrib/rstan_2.21.2.tar.gz
Content type ‘application/x-gzip’ length 1152008 bytes (1.1 MB)

downloaded 1.1 MB

trying URL ‘http://cloud.r-project.org/src/contrib/mgcv_1.8-33.tar.gz
Content type ‘application/x-gzip’ length 1004417 bytes (980 KB)

downloaded 980 KB

trying URL ‘http://cloud.r-project.org/src/contrib/shinystan_2.5.0.tar.gz
Content type ‘application/x-gzip’ length 2400413 bytes (2.3 MB)

downloaded 2.3 MB

trying URL ‘http://cloud.r-project.org/src/contrib/nleqslv_3.3.2.tar.gz
Content type ‘application/x-gzip’ length 83731 bytes (81 KB)

downloaded 81 KB

trying URL ‘http://cloud.r-project.org/src/contrib/rtdists_0.11-2.tar.gz
Content type ‘application/x-gzip’ length 867210 bytes (846 KB)

downloaded 846 KB

trying URL ‘http://cloud.r-project.org/src/contrib/spdep_1.1-5.tar.gz
Content type ‘application/x-gzip’ length 2867051 bytes (2.7 MB)

downloaded 2.7 MB

trying URL ‘http://cloud.r-project.org/src/contrib/mnormt_2.0.2.tar.gz
Content type ‘application/x-gzip’ length 50606 bytes (49 KB)

downloaded 49 KB

trying URL ‘http://cloud.r-project.org/src/contrib/MCMCglmm_2.29.tar.gz
Content type ‘application/x-gzip’ length 5745025 bytes (5.5 MB)

downloaded 5.5 MB

trying URL ‘http://cloud.r-project.org/src/contrib/splines2_0.3.1.tar.gz
Content type ‘application/x-gzip’ length 419686 bytes (409 KB)

downloaded 409 KB

trying URL ‘http://cloud.r-project.org/src/contrib/ape_5.4-1.tar.gz
Content type ‘application/x-gzip’ length 798605 bytes (779 KB)

downloaded 779 KB

trying URL ‘http://cloud.r-project.org/src/contrib/arm_1.11-2.tar.gz
Content type ‘application/x-gzip’ length 79464 bytes (77 KB)

downloaded 77 KB

trying URL ‘http://cloud.r-project.org/src/contrib/afex_0.28-0.tar.gz
Content type ‘application/x-gzip’ length 2755737 bytes (2.6 MB)

downloaded 2.6 MB

trying URL ‘http://cloud.r-project.org/src/contrib/phia_0.2-1.tar.gz
Content type ‘application/x-gzip’ length 547339 bytes (534 KB)

downloaded 534 KB

trying URL ‘http://cloud.r-project.org/src/contrib/lmerTest_3.1-2.tar.gz
Content type ‘application/x-gzip’ length 194611 bytes (190 KB)

downloaded 190 KB

trying URL ‘http://cloud.r-project.org/src/contrib/brms_2.13.5.tar.gz
Content type ‘application/x-gzip’ length 4469218 bytes (4.3 MB)

downloaded 4.3 MB

ERROR: failed to lock directory ‘/home/cslaw/R’ for modifying
Try removing ‘/home/cslaw/R/00LOCK-data.table’
ERROR: failed to lock directory ‘/home/cslaw/R’ for modifying
Try removing ‘/home/cslaw/R/00LOCK-hexbin’
ERROR: failed to lock directory ‘/home/cslaw/R’ for modifying
Try removing ‘/home/cslaw/R/00LOCK-robustbase’
ERROR: failed to lock directory ‘/home/cslaw/R’ for modifying
Try removing ‘/home/cslaw/R/00LOCK-openssl’

  • installing source package ‘units’ …
    ** package ‘units’ successfully unpacked and MD5 sums checked
    ** using staged installation
    configure: units: 0.6-7
    checking whether the C++ compiler works… yes
    checking for C++ compiler default output file name… a.out
    checking for suffix of executables…
    checking whether we are cross compiling… no
    checking for suffix of object files… o
    checking whether we are using the GNU C++ compiler… yes
    checking whether g++ -std=gnu++11 accepts -g… yes
    checking how to run the C++ preprocessor… g++ -std=gnu++11 -E
    checking for grep that handles long lines and -e… /bin/grep
    checking for egrep… /bin/grep -E
    checking for ANSI C header files… yes
    checking for sys/types.h… yes
    checking for sys/stat.h… yes
    checking for stdlib.h… yes
    checking for string.h… yes
    checking for memory.h… yes
    checking for strings.h… yes
    checking for inttypes.h… yes
    checking for stdint.h… yes
    checking for unistd.h… yes
    checking for stdbool.h that conforms to C99… no
    checking for _Bool… no
    checking for error_at_line… yes
    checking for gcc… gcc -std=gnu99
    checking whether we are using the GNU C compiler… yes
    checking whether gcc -std=gnu99 accepts -g… yes
    checking for gcc -std=gnu99 option to accept ISO C89… none needed
    checking for XML_ParserCreate in -lexpat… no
    checking udunits2.h usability… no
    checking udunits2.h presence… no
    checking for udunits2.h… no
    checking udunits2/udunits2.h usability… no
    checking udunits2/udunits2.h presence… no
    checking for udunits2/udunits2.h… no
    checking for ut_read_xml in -ludunits2… no
    configure: error: in `/tmp/RtmpRcXr0P/R.INSTALL25d92457a417/units’:
    configure: error:

Configuration failed because libudunits2.so was not found. Try installing:
* deb: libudunits2-dev (Debian, Ubuntu, …)
* rpm: udunits2-devel (Fedora, EPEL, …)
* brew: udunits (OSX)
If udunits2 is already installed in a non-standard location, use:
–configure-args=‘–with-udunits2-lib=/usr/local/lib’
if the library was not found, and/or:
–configure-args=‘–with-udunits2-include=/usr/include/udunits2’
if the header was not found, replacing paths with appropriate values.
You can alternatively set UDUNITS2_INCLUDE and UDUNITS2_LIBS manually.

See `config.log’ for more details
ERROR: configuration failed for package ‘units’

  • removing ‘/home/cslaw/R/units’
    ERROR: failed to lock directory ‘/home/cslaw/R’ for modifying
    Try removing ‘/home/cslaw/R/00LOCK-cluster’
  • installing source package ‘libcoin’ …
    ** package ‘libcoin’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/mvtnorm/include" -fvisibility=hidden -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c libcoin-init.c -o libcoin-init.o
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/mvtnorm/include" -fvisibility=hidden -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c libcoin.c -o libcoin.o
    gcc -std=gnu99 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o libcoin.so libcoin-init.o libcoin.o -llapack -lblas -lgfortran -lm -lquadmath -L/usr/lib/R/lib -lR
    /usr/bin/ld: cannot find -llapack
    /usr/bin/ld: cannot find -lblas
    collect2: error: ld returned 1 exit status
    make: *** [/usr/share/R/share/make/shlib.mk:6: libcoin.so] Error 1
    ERROR: compilation failed for package ‘libcoin’
  • removing ‘/home/cslaw/R/libcoin’
  • installing source package ‘jpeg’ …
    ** package ‘jpeg’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c read.c -o read.o
    In file included from read.c:1:
    rjcommon.h:11:10: fatal error: jpeglib.h: No such file or directory
    11 | #include <jpeglib.h>
    | ^~~~~~~~~~~
    compilation terminated.
    make: *** [/usr/lib/R/etc/Makeconf:168: read.o] Error 1
    ERROR: compilation failed for package ‘jpeg’
  • removing ‘/home/cslaw/R/jpeg’
  • installing source package ‘V8’ …
    ** package ‘V8’ successfully unpacked and MD5 sums checked
    ** using staged installation
    Using PKG_CFLAGS=-I/usr/include/v8 -I/usr/include/v8-3.14
    Using PKG_LIBS=-lv8 -lv8_libplatform
    -----------------------------[ ANTICONF ]-------------------------------
    Configuration failed to find the libv8 engine library. Try installing:
  • deb: libv8-dev or libnode-dev (Debian / Ubuntu)
  • rpm: v8-devel (Fedora, EPEL)
  • brew: v8 (OSX)
  • csw: libv8_dev (Solaris)
    To use a custom libv8, set INCLUDE_DIR and LIB_DIR manually via:
    R CMD INSTALL --configure-vars=‘INCLUDE_DIR=… LIB_DIR=…’
    ---------------------------[ ERROR MESSAGE ]----------------------------
    :1:10: fatal error: v8.h: No such file or directory
    compilation terminated.

ERROR: configuration failed for package ‘V8’

  • removing ‘/home/cslaw/R/V8’
  • installing source package ‘gsl’ …
    ** package ‘gsl’ successfully unpacked and MD5 sums checked
    ** using staged installation
    checking for gsl-config… no
    configure: error: gsl-config not found, is GSL installed?
    ERROR: configuration failed for package ‘gsl’
  • removing ‘/home/cslaw/R/gsl’
  • installing source package ‘tmvnsim’ …
    ** package ‘tmvnsim’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c Fortran2CWrapper.c -o Fortran2CWrapper.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c tmvnghk.f90 -o tmvnghk.o
    gcc -std=gnu99 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o tmvnsim.so Fortran2CWrapper.o tmvnghk.o -llapack -lblas -lgfortran -lm -lquadmath -lgfortran -lm -lquadmath -L/usr/lib/R/lib -lR
    /usr/bin/ld: cannot find -llapack
    /usr/bin/ld: cannot find -lblas
    collect2: error: ld returned 1 exit status
    make: *** [/usr/share/R/share/make/shlib.mk:6: tmvnsim.so] Error 1
    ERROR: compilation failed for package ‘tmvnsim’
  • removing ‘/home/cslaw/R/tmvnsim’
  • installing source package ‘RcppArmadillo’ …
    ** package ‘RcppArmadillo’ successfully unpacked and MD5 sums checked
    ** using staged installation
    checking whether the C++ compiler works… yes
    checking for C++ compiler default output file name… a.out
    checking for suffix of executables…
    checking whether we are cross compiling… no
    checking for suffix of object files… o
    checking whether we are using the GNU C++ compiler… yes
    checking whether g++ -std=gnu++11 accepts -g… yes
    checking how to run the C++ preprocessor… g++ -std=gnu++11 -E
    checking whether we are using the GNU C++ compiler… (cached) yes
    checking whether g++ -std=gnu++11 accepts -g… (cached) yes
    checking whether we have a suitable tempdir… /tmp
    checking whether R CMD SHLIB can already compile programs using OpenMP… yes
    checking LAPACK_LIBS… system LAPACK found
    configure: creating ./config.status
    config.status: creating inst/include/RcppArmadilloConfigGenerated.h
    config.status: creating src/Makevars
    ** libs
    g++ -std=gnu++11 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/Rcpp/include" -I…/inst/include -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c RcppArmadillo.cpp -o RcppArmadillo.o
    g++ -std=gnu++11 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/Rcpp/include" -I…/inst/include -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c RcppExports.cpp -o RcppExports.o
    g++ -std=gnu++11 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/Rcpp/include" -I…/inst/include -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c fastLm.cpp -o fastLm.o
    g++ -std=gnu++11 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o RcppArmadillo.so RcppArmadillo.o RcppExports.o fastLm.o -llapack -lblas -lgfortran -lm -lquadmath -L/usr/lib/R/lib -lR
    /usr/bin/ld: cannot find -llapack
    /usr/bin/ld: cannot find -lblas
    collect2: error: ld returned 1 exit status
    make: *** [/usr/share/R/share/make/shlib.mk:6: RcppArmadillo.so] Error 1
    ERROR: compilation failed for package ‘RcppArmadillo’
  • removing ‘/home/cslaw/R/RcppArmadillo’
  • installing source package ‘Matrix’ …
    ** package ‘Matrix’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -DNTIMER -I./SuiteSparse_config -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c CHMfactor.c -o CHMfactor.o
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -DNTIMER -I./SuiteSparse_config -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c Csparse.c -o Csparse.o


make[2]: Leaving directory ‘/tmp/RtmpjkT8PB/R.INSTALL2ca8d17e50b/Matrix/src/AMD/Source’
make[1]: Leaving directory ‘/tmp/RtmpjkT8PB/R.INSTALL2ca8d17e50b/Matrix/src/AMD’
make[1]: Entering directory ‘/tmp/RtmpjkT8PB/R.INSTALL2ca8d17e50b/Matrix/src/SuiteSparse_config’
gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -DNTIMER -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c SuiteSparse_config.c -o SuiteSparse_config.o
ar -rucs …/SuiteSparse_config.a SuiteSparse_config.o
ar: u' modifier ignored since D’ is the default (see `U’)
make[1]: Leaving directory ‘/tmp/RtmpjkT8PB/R.INSTALL2ca8d17e50b/Matrix/src/SuiteSparse_config’
gcc -std=gnu99 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o Matrix.so CHMfactor.o Csparse.o TMatrix_as.o Tsparse.o init.o Mutils.o chm_common.o cs.o cs_utils.o dense.o dgCMatrix.o dgTMatrix.o dgeMatrix.o dpoMatrix.o dppMatrix.o dsCMatrix.o dsyMatrix.o dspMatrix.o dtCMatrix.o dtTMatrix.o dtrMatrix.o dtpMatrix.o factorizations.o ldense.o lgCMatrix.o sparseQR.o abIndex.o CHOLMOD.a COLAMD.a AMD.a SuiteSparse_config.a -llapack -lblas -lgfortran -lm -lquadmath -L/usr/lib/R/lib -lR
/usr/bin/ld: cannot find -llapack
/usr/bin/ld: cannot find -lblas
collect2: error: ld returned 1 exit status
make: *** [/usr/share/R/share/make/shlib.mk:6: Matrix.so] Error 1
ERROR: compilation failed for package ‘Matrix’

  • removing ‘/home/cslaw/R/Matrix’
  • installing source package ‘nleqslv’ …
    ** package ‘nleqslv’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c init.c -o init.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c lautil.f -o lautil.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c limhpar.f -o limhpar.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c liqrev.f -o liqrev.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c liqrup.f -o liqrup.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c lirslv.f -o lirslv.o
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c nleqslv.c -o nleqslv.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwbjac.f -o nwbjac.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwbrdn.f -o nwbrdn.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwclsh.f -o nwclsh.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwddlg.f -o nwddlg.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwglsh.f -o nwglsh.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwmhlm.f -o nwmhlm.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwnjac.f -o nwnjac.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwnleq.f -o nwnleq.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwnwtn.f -o nwnwtn.o
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c nwout.c -o nwout.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwpdlg.f -o nwpdlg.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwpure.f -o nwpure.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwqlsh.f -o nwqlsh.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwtrup.f -o nwtrup.o
    gfortran -fno-optimize-sibling-calls -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -c nwutil.f -o nwutil.o
    gcc -std=gnu99 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o nleqslv.so init.o lautil.o limhpar.o liqrev.o liqrup.o lirslv.o nleqslv.o nwbjac.o nwbrdn.o nwclsh.o nwddlg.o nwglsh.o nwmhlm.o nwnjac.o nwnleq.o nwnwtn.o nwout.o nwpdlg.o nwpure.o nwqlsh.o nwtrup.o nwutil.o -llapack -lblas -lgfortran -lm -lquadmath -lgfortran -lm -lquadmath -L/usr/lib/R/lib -lR
    /usr/bin/ld: cannot find -llapack
    /usr/bin/ld: cannot find -lblas
    collect2: error: ld returned 1 exit status
    make: *** [/usr/share/R/share/make/shlib.mk:6: nleqslv.so] Error 1
    ERROR: compilation failed for package ‘nleqslv’
  • removing ‘/home/cslaw/R/nleqslv’
  • installing source package ‘ape’ …
    ** package ‘ape’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/Rcpp/include" -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c BIONJ.c -o BIONJ.o
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/Rcpp/include" -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c NNI.c -o NNI.o
    g++ -std=gnu++11 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/Rcpp/include" -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c RcppExports.cpp -o RcppExports.o
    gcc -std=gnu99 -I"/usr/share/R/include" -DNDEBUG -I"/home/cslaw/R/Rcpp/include" -fpic -g -O2 -fdebug-prefix-map=/build/r-base-jbaK_j/r-base-3.6.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -g -c SPR.c -o SPR.o

g++ -std=gnu++11 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o ape.so BIONJ.o NNI.o RcppExports.o SPR.o additive.o ape.o bNNI.o bionjs.o bipartition.o bitsplits.o delta_plot.o dist_dna.o dist_nodes.o ewLasso.o heap.o mat_expo.o me.o me_balanced.o me_ols.o mvr.o mvrs.o nj.o njs.o pic.o plot_phylo.o prop_part.o rTrait.o read_dna.o reorder_Rcpp.o reorder_phylo.o treePop.o tree_build.o tree_phylo.o triangMtd.o triangMtds.o ultrametric.o -llapack -lblas -lgfortran -lm -lquadmath -L/usr/lib/R/lib -lR
/usr/bin/ld: cannot find -llapack
/usr/bin/ld: cannot find -lblas
collect2: error: ld returned 1 exit status
make: *** [/usr/share/R/share/make/shlib.mk:6: ape.so] Error 1
ERROR: compilation failed for package ‘ape’

  • removing ‘/home/cslaw/R/ape’
    ERROR: dependencies ‘Matrix’, ‘RcppArmadillo’ are not available for package ‘conquer’
  • removing ‘/home/cslaw/R/conquer’
    ERROR: dependency ‘openssl’ is not available for package ‘httr’
  • removing ‘/home/cslaw/R/httr’
    ERROR: failed to lock directory ‘/home/cslaw/R’ for modifying
    Try removing ‘/home/cslaw/R/00LOCK-igraph’
    ERROR: dependency ‘Matrix’ is not available for package ‘RcppEigen’
  • removing ‘/home/cslaw/R/RcppEigen’
    ERROR: dependencies ‘foreign’, ‘data.table’ are not available for package ‘rio’
  • removing ‘/home/cslaw/R/rio’
    ERROR: dependency ‘Matrix’ is not available for package ‘survival’
  • removing ‘/home/cslaw/R/survival’
    ERROR: dependency ‘robustbase’ is not available for package ‘qqplotr’
  • removing ‘/home/cslaw/R/qqplotr’
    ERROR: dependency ‘openssl’ is not available for package ‘rsconnect’
  • removing ‘/home/cslaw/R/rsconnect’
    ERROR: dependency ‘units’ is not available for package ‘sf’
  • removing ‘/home/cslaw/R/sf’
    ERROR: dependency ‘Matrix’ is not available for package ‘expm’
  • removing ‘/home/cslaw/R/expm’
    ERROR: dependency ‘jpeg’ is not available for package ‘latticeExtra’
  • removing ‘/home/cslaw/R/latticeExtra’
    ERROR: dependency ‘Matrix’ is not available for package ‘mgcv’
  • removing ‘/home/cslaw/R/mgcv’
    ERROR: dependency ‘tmvnsim’ is not available for package ‘mnormt’
  • removing ‘/home/cslaw/R/mnormt’
    ERROR: dependencies ‘Matrix’, ‘ape’ are not available for package ‘MCMCglmm’
  • removing ‘/home/cslaw/R/MCMCglmm’
    ERROR: dependency ‘RcppArmadillo’ is not available for package ‘splines2’
  • removing ‘/home/cslaw/R/splines2’
    ERROR: dependencies ‘Matrix’, ‘conquer’ are not available for package ‘quantreg’
  • removing ‘/home/cslaw/R/quantreg’
    ERROR: dependency ‘mnormt’ is not available for package ‘psych’
  • removing ‘/home/cslaw/R/psych’
    ERROR: dependencies ‘Matrix’, ‘RcppEigen’ are not available for package ‘TMB’
  • removing ‘/home/cslaw/R/TMB’
    ERROR: dependency ‘RcppEigen’ is not available for package ‘StanHeaders’
  • removing ‘/home/cslaw/R/StanHeaders’
    ERROR: dependencies ‘httr’, ‘hexbin’, ‘data.table’ are not available for package ‘plotly’
  • removing ‘/home/cslaw/R/plotly’
    ERROR: dependency ‘igraph’ is not available for package ‘threejs’
  • removing ‘/home/cslaw/R/threejs’
    ERROR: dependencies ‘survival’, ‘expm’ are not available for package ‘msm’
  • removing ‘/home/cslaw/R/msm’
    ERROR: dependencies ‘survival’, ‘latticeExtra’, ‘cluster’, ‘foreign’, ‘data.table’ are not available for package ‘Hmisc’
  • removing ‘/home/cslaw/R/Hmisc’
    ERROR: dependencies ‘Matrix’, ‘RcppEigen’ are not available for package ‘lme4’
  • removing ‘/home/cslaw/R/lme4’
    ERROR: dependencies ‘survival’, ‘libcoin’ are not available for package ‘coin’
  • removing ‘/home/cslaw/R/coin’
    ERROR: dependencies ‘sf’, ‘Matrix’, ‘expm’ are not available for package ‘spdep’
  • removing ‘/home/cslaw/R/spdep’
    ERROR: dependencies ‘lme4’, ‘Matrix’ are not available for package ‘pbkrtest’
  • removing ‘/home/cslaw/R/pbkrtest’
    ERROR: dependency ‘lme4’ is not available for package ‘mlmRev’
  • removing ‘/home/cslaw/R/mlmRev’
    ERROR: dependencies ‘foreign’, ‘psych’ are not available for package ‘psychTools’
  • removing ‘/home/cslaw/R/psychTools’
    ERROR: dependency ‘lme4’ is not available for package ‘MEMSS’
  • removing ‘/home/cslaw/R/MEMSS’
    ERROR: dependency ‘lme4’ is not available for package ‘effects’
  • removing ‘/home/cslaw/R/effects’
    ERROR: dependencies ‘TMB’, ‘lme4’, ‘Matrix’, ‘RcppEigen’ are not available for package ‘glmmTMB’
  • removing ‘/home/cslaw/R/glmmTMB’
    ERROR: dependencies ‘plotly’, ‘qqplotr’ are not available for package ‘ggResidpanel’
  • removing ‘/home/cslaw/R/ggResidpanel’
    ERROR: dependencies ‘StanHeaders’, ‘V8’, ‘RcppEigen’ are not available for package ‘rstan’
  • removing ‘/home/cslaw/R/rstan’
    ERROR: dependencies ‘msm’, ‘gsl’ are not available for package ‘rtdists’
  • removing ‘/home/cslaw/R/rtdists’
    ERROR: dependencies ‘Matrix’, ‘lme4’, ‘Hmisc’ are not available for package ‘arm’
  • removing ‘/home/cslaw/R/arm’
    ERROR: dependency ‘lme4’ is not available for package ‘lmerTest’
  • removing ‘/home/cslaw/R/lmerTest’
    ERROR: dependencies ‘mgcv’, ‘pbkrtest’, ‘quantreg’, ‘rio’, ‘lme4’ are not available for package ‘car’
  • removing ‘/home/cslaw/R/car’
    ERROR: dependencies ‘rsconnect’, ‘rstan’, ‘threejs’ are not available for package ‘shinystan’
  • removing ‘/home/cslaw/R/shinystan’
    ERROR: dependency ‘car’ is not available for package ‘rstatix’
  • removing ‘/home/cslaw/R/rstatix’
    ERROR: dependencies ‘lme4’, ‘Matrix’, ‘rstan’, ‘shinystan’, ‘survival’, ‘StanHeaders’, ‘RcppEigen’ are not available for package ‘rstanarm’
  • removing ‘/home/cslaw/R/rstanarm’
    ERROR: dependencies ‘lme4’, ‘pbkrtest’, ‘lmerTest’, ‘car’ are not available for package ‘afex’
  • removing ‘/home/cslaw/R/afex’
    ERROR: dependencies ‘car’, ‘Matrix’ are not available for package ‘phia’
  • removing ‘/home/cslaw/R/phia’
    ERROR: dependencies ‘rstan’, ‘Matrix’, ‘mgcv’, ‘shinystan’, ‘nleqslv’ are not available for package ‘brms’
  • removing ‘/home/cslaw/R/brms’
    ERROR: dependency ‘rstatix’ is not available for package ‘ggpubr’
  • removing ‘/home/cslaw/R/ggpubr’

The downloaded source packages are in
‘/tmp/RtmpkOueVY/downloaded_packages’

++ Note: @ 22:06:05
This package has been installed on the computer: afex
This package has been installed on the computer: phia
This package has been installed on the computer: lmerTest
This package has been installed on the computer: brms

There were 50 or more warnings (use warnings() to see the first 50)

Hi, Christine-

OK, it looks like the symbolic link exists. Just to verify it, what is the output of:


ls -l /usr/lib/x86_64-linux-gnu/libgsl.so.23

?

Since the GSL link exists, I wonder if the problem is with the GSL installation itself. I also find it odd that you would have to install libglu1 separately, because the main installation command has “libglu1-mesa-dev” as part of its installation, and I would just assume that plain ol’ libglu1 would be a dependency of that… Just to rule out something like that, could you please run these three commands again via copy+paste into the terminal:


sudo add-apt-repository universe


sudo apt-get update

(This is the main installation command without the R part, because you have been working on that separately):


sudo apt-get install -y tcsh xfonts-base libssl-dev       \
                        python-is-python3                 \
                        python3-matplotlib                \
                        gsl-bin netpbm gnome-tweak-tool   \
                        libjpeg62 xvfb xterm vim curl     \
                        gedit evince eog                  \
                        libglu1-mesa-dev libglw1-mesa     \
                        libxm4 build-essential            \
                        libcurl4-openssl-dev libxml2-dev  \
                        libgfortran-8-dev libgomp1        \
                        gnome-terminal nautilus           \
                        gnome-icon-theme-symbolic         \
                        firefox xfonts-100dpi     

If you run afni_system_check.py after that, are there still errors?

–pt

Hi Christine,

Just to expand Paul’s first command a bit, what is the output from:

ls -l /usr/lib/x86_64-linux-gnu/libgsl.so*

Thanks,

  • rick

cslaw@mackeylab1027:~$ ls -l /usr/lib/x86_64-linux-gnu/libgsl.so*
lrwxrwxrwx 1 root root 38 Oct 7 21:58 /usr/lib/x86_64-linux-gnu/libgsl.so.19 → /usr/lib/x86_64-linux-gnu/libgsl.so.23

Sorry for not seeing this for so long. But that means you have not actually installed the library.
And looking, I see that it is missing from the install instructions! We need to update that.

Try:

sudo apt-get install gsl-bin

Please let us know how it goes.

  • rick

Paul noted that I missed the gsl-bin package on the install page, it is indeed there.

So maybe you missed that part of the instruction. Please run the prerequisite package install commands on that page and see how it goes.

Thanks,

  • rick