Cluster Explorer


I’m trying to use Cluster Explorer and I keep running into errors.

When I run I get the following error:

Traceback (most recent call last):
File “/home/dxc536/abin/”, line 144, in
if not (“3dttest++” in hist_all or “3dMVM” or “3dLME” in hist_all):
TypeError: a bytes-like object is required, not 'str

So, I decided to skip the step and create my own .csv by hand. However, when I run I get the following error:

Traceback (most recent call last):
File “/home/dxc536/abin/”, line 20, in
HistProg = afni_dir+“/”
TypeError: can’t concat str to bytes

Any thoughts?


Can you post your commands and the output of: -check_all


Also, if possible can you email your csv file to

Thanks, Justin

Thanks. I just sent the email. See below for the output:

-------------------------------- general ---------------------------------
architecture: 64bit ELF
system: Linux
release: 5.4.0-88-generic
version: #99-Ubuntu SMP Thu Sep 23 17:29:00 UTC 2021
distribution: Ubuntu 20.04.1 LTS
number of CPUs: 8
apparent login shell: bash
shell RC file: .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /home/dxc536/abin/afni
afni version : Precompiled binary linux_ubuntu_16_64: Jan 11 2021
: AFNI_21.0.02 ‘Titus’
AFNI_version.txt : AFNI_21.0.02, linux_ubuntu_16_64, Jan 11 2021
which python : /home/dxc536/miniconda3/bin/python
python version : 3.9.5
which R : /usr/bin/R
R version : R version 3.6.3 (2020-02-29) – “Holding the Windsock”
which tcsh : /usr/bin/tcsh

instances of various programs found in PATH:
afni : 1 (/home/dxc536/abin/afni)
R : 1 (/usr/bin/R)
python : 2
python2 : 1 (/usr/bin/python2.7)
python3 : 2

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : success : success
3dAllineate : success
3dRSFC : success
SurfMesh : success
3dClustSim : success
3dMVM : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : success

R RHOME : /usr/lib/R

checking for $HOME files…
.afnirc : found
.sumarc : found
.afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** failed to load module PyQt4
– PyQt4 is no longer needed for an AFNI bootcamp

** failed to load module matplotlib.pyplot
– matplotlib.pyplot is not required, but is desirable

-------------------------------- env vars --------------------------------
PATH = /home/dxc536/miniconda3/bin:/home/dxc536/miniconda3/condabin:/home/dxc536/ImagingScripts/gauss_scripts:/media/dxc536/UNLOCKER/linux:/home/dxc536/ImagingScripts/pestica_afni_v5.2/slomoco:/home/dxc536/ImagingScripts/pestica_afni_v5.2:/usr/local/fsl/bin:/usr/local/fsl/bin:/home/dxc536/bin:/home/dxc536/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/dxc536/abin

R_LIBS = /home/dxc536/R


------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /home/dxc536/abin

------------------------------ OS specific -------------------------------
which apt-get : /usr/bin/apt-get
apt-get version : apt 2.0.2ubuntu0.2 (amd64)

have Ubuntu system: Ubuntu 20.04.1 LTS
have Ubuntu afni : Precompiled binary linux_ubuntu_16_64: Jan 11 2021

========================= summary, please fix: =========================

  • just be aware: login shell ‘bash’, but our code examples use ‘tcsh’
  • insufficient data for AFNI bootcamp