should have option for -nomask/weight


I can’t get to run without using an autoweight in 3dAllineate. From the documentation, I would think passing 3dAllineate_opts “-nomask” should do the trick, but it doesn’t:

#++ Aligning dset1 data to dset2 data
#Script is running (command trimmed):
3dAllineate -mi -wtprefix ./__tt_mr_pre_ob_al_wtal -weight ./__tt_ct_implant_res_shft_ts_wt+orig -source ./__tt_mr_pre_ob+orig -prefix ./__tt_mr_pre_ob_temp_al -base ./__tt_ct_implant_res_shft_ts+orig -nocmass -1Dmatrix_save ./mr_pre_al_e2a_only_mat.aff12.1D -master SOURCE -nomask -onepass

As you can see, the -nomask argument indeed gets passed to the 3dAllineate call, but so does an auto-weight. It turns out that my alignments have a higher success rate (and I can avoid “weight is never positive” errors) if I don’t use any weights. The work-around I’m currently using is to break the script at this point, copy the 3dAllineate comman, delete the “-weight” arguments, run the modified allineate command, and then rerun the rest of’s commands.

Am I missing something in the documentation regarding this option?