fails with -edge in -align_opts_aea

Dear AFNI experts and developers,
Hopefully I’m just missing something basic, but this one has me stumped.
I’m trying to use to pre-process some resting state fMRI data. For a couple of the subjects, alignment of the structural to the functional was giving me trouble until I used the “-edge” option. That fixed the alignment in separate testing using However, when I simply replace the “-cost lpc+” argument that I was using before with “-edge” in the relevant part of, it throws this error:

cat_matvec -ONELINE anatQQ.28864.aff12.1D anatSS.28864_al_junk_mat.aff12.1D -I mat.r01.vr.aff12.1D
** ERROR: mri_read_ascii: couldn’t open file anatSS.28864_al_junk_mat.aff12.1D
** FATAL ERROR: Can’t read file ‘anatSS.28864_al_junk_mat.aff12.1D’
** Program compile date = May 11 2021

Here’s the command that produces that error:
-subj_id $subj
-dsets rest+orig
-blocks despike tshift align tlrc volreg blur mask scale regress
-copy_anat ./anat_warped/anatSS.$subj.nii
-anat_has_skull no
-anat_follower anat_w_skull anat ./$subj/SUMA/${subj}_SurfVol.nii
-anat_follower_ROI aaseg anat ./$subj/SUMA/aparc.a2009s+aseg.nii.gz
-anat_follower_ROI aeseg epi ./$subj/SUMA/aparc.a2009s+aseg.nii.gz
-anat_follower_ROI FSvent epi ./$subj/SUMA/fs_ap_latvent.nii.gz
-anat_follower_ROI FSWe epi ./$subj/SUMA/fs_ap_wm.nii.gz
-anat_follower_erode FSvent FSWe
-tcat_remove_first_trs 2
-align_opts_aea -epi_strip 3dSkullStrip -edge -check_flip
-tlrc_base /usr/lib/afni/bin/MNI152_2009_template_SSW.nii.gz
-tlrc_NL_warped_dsets ./anat_warped/anatQQ.$subj.nii ./anat_warped/anatQQ.$subj.aff12.1D ./anat_warped/anatQQ.${subj}_WARP.nii
-volreg_align_to MIN_OUTLIER
-mask_epi_anat yes
-regress_censor_motion 0.3
-regress_censor_outliers 0.1
-regress_apply_mot_types demean deriv
-html_review_style pythonic

Again, all I have to do is replace “-edge” with “-cost lpc+” to make the error go away. But then the alignment isn’t as good! I’d appreciate any help you can give.

That edge option in had a small bug in the matrix output naming that doesn’t work with I’ve fixed it now and pushed it for future distributions. Thanks for letting me know!

Just tested it with your latest version and it works like a charm now. Thank you!