afni proc, align_opts_aea not correctly applied

Hey afni folks,

I am attempting to use 3dSkullStrip rather than 3dAutomask for anatomical to epi alignment, via

-align_opts_aea -cost lpc+ZZ -epi_strip 3dSkullStrip

When I check the proc script produced, the align section shows the call contains both -epi_strip options, the default (first) and my request - but looking in the script output file, only 3dAutoMask is used to produce the ‘skull stripped’ epi,

3dAutoMask -apply_prefix ./__tt_vr_base_ts_rs_ns ./__tt_vr_base_ts_rs+orig

I can imagine a work around (skull strip the epi, and use that as a the volreg target) but I wanted to bring this to your attention. Perhaps I have done something wrong in the way that it is called, by placing the -epi_strip call last?


If only I had scrolled down slightly in the afni proc help, rather than jumping to align_epi_anat.

Solution is already built in, via

-align_epi_strip_method METHOD : specify EPI skull strip method in AEA

The AFNI wizards continue to think of (almost?) everything…

The automask method is the default in for masking the EPI dataset. Have you run into a situation where it doesn’t work? Skullstripping for the anatomical dataset is done typically with 3dSkullstrip, or the newer @SSwarper.

I wanted to use 3dskullstrip on the epi data as part of align_epi_anat, as I thought 3dautomask was causing problems and leading to poor registration. In the end, turning off deoblique (-deoblique off) seemed to resolve the problem, strangely enough.

It was a troublesome and strange problem, as the whole brain epi and anat were very closely aligned to start with, nearly matched, but in some cases align_epi_anat was producing extraordinarily bad alignments, shifting half the brain out of the FOV, and stretching wildly.

@SSwarper worked well for 58/60 of the subjects - on two it appears to have ran into an issue during skull stripping - leaving far too much tissue around the brain, such that the MNI warped brain is very small. I’m still looking into that.

I am having the same problem with @SSwaper not fully stripping the skull in some datasets, leading to skull being warped as “brain.” Were you able to find a solution to this? I don’t see any options that would deal with this in 3dSkullStrip to pass to @SSwarper via the -ssopt.


Hi, Becca-

There have been some recent updates to @SSwarper that might address this; what is your AFNI version, i.e., the output of

afni -ver


AFNI versions of 20.0.03 and higher should have this update. (Though I note there are a couple further things I have been thinking about adding, too, but am Bootcamping at the moment so it will be a little while before I get to those.)


@update.afni.binaries -d


afni -ver
Precompiled binary linux_openmp_64: Mar 15 2019 (Version AFNI_19.0.25 ‘Tiberius’)

I will try updating the binaries and see if that helps.