AFNI GIC: connection to 3dGroupInCorr is broken

Hi gurus…

We have been been having some issues when dynamically working with 3dGroupInCorr (when being logged in remotely on a server with afni installed). The user computer is a Windows Computer and the same issue occurs when connecting via either MobaXterm or Putty.

EDIT: The same error occurs when running it via ThinLinc (i.e. a remote desktop session). So it does not seem to depend on how you connect to the server. One would probably get the same error if you ran it from the server room in a local session.

EDIT: Afni version:
Precompiled binary linux_openmp_64: Aug 9 2017 (Version AFNI_17.2.07)

We seem to have found what causes it. It is no trouble changing seed region until you open the Where I’m I function. If you change seed when that window is open it crashes. Even if you close Where Im I before changing​ the seed it gets the connection broken error.!

Ideas of why?

Thanks!

I’m not sure WHY, but you could try a workaround.
On the 3dGroupInCorr command, add the option ‘-ah 127.0.0.1’ to force the connection to use TCP/IP rather than shared memory (which is faster). This might work better.

I’m off to teach an AFNI bootcamp, leaving tomorrow (Fri Dec 1) morning, so I won’t be available to answer questions for a while.

Maybe this is just the whereami function by itself. Try opening the whereami window without doing any other insta… functions. whereami needs to be able to find atlases, but it should just report an error. Are your datasets in a standard space like MNI or TLRC? You can also try using whereami from the command line.

Hi and thanks!

It is quite strange. Depending on the order you do things the error some times does not occur. But you get the “connection to 3dGroupInCorr is broken” a 100 % of the times if you do:


afni -niml &
3dGroupInCorr -setA file.grpincorr.niml
Overlay: file.grpincorr
Setup GICor (set seed radious) Set + Quit 
Change OLay and Thr to Z-scores
Clusterize (20) Set+ Quit
set p to 0.05
Ctrl+Shift+Left Click a seed
Right click and start Where Am i
Ctrl+Shift+Left Click a new seed location

You seem to be able to avoid the error by:

  1. The same procedure as above but start Where Am I before you select a seed Shift+Ctrl+Left Click

  2. Or, as you suggested, by doing the procedure above but running:


3dGroupInCorr -ah 127.0.0.1  -setA file.grpincorr.niml

This seems to be the most robust solution since the outcome of 1) seem to randomly change depending on a certain order of actions…