AFNI Crashing?

I am running a processing script on some Nifti files. The script produces a lot of files, the most important being an html page that displays connectivity maps, motion charts, and statistical data. I have run this script multiple times with many data sets, and I keep getting incomplete results, namely no connectivity maps and some statistical data missing. The following message shows up repeatedly in the output log.
++ If you are using XQuartz 2.7.10 (or later), and AFNI crashes when

  • opening windows, or you cannot type text into AFNI popup windows,
  • you might need to set an environment variable to solve this problem:
  • setenv DYLD_LIBRARY_PATH /opt/X11/lib/flat_namespace # tcsh
  • export DYLD_LIBRARY_PATH=/opt/X11/lib/flat_namespace # bash
  • This command is best put in your startup ~/.cshrc file, so that
  • it will be invoked for every (t)csh shell you open (mutatis mutandis
  • for the bash shell, of course).
  • If things are OK and you want to avoid having this warning message
  • pollute your terminal, use this:
  • setenv AFNI_SKIP_DYLD_WARNING YES # tcsh
  • export AFNI_SKIP_DYLD_WARNING=YES # bash


Fatal Signal 11 (SIGSEGV) received
Last STATUS: making imag->rowcol
Bottom of Debug Stack
** AFNI version = AFNI_21.3.01 Compile date = Oct 12 2021
** [[Precompiled binary macos_10.12_local: Oct 12 2021]]
** Program Death **
** If you report this crash to the AFNI message board,
** please copy the error messages EXACTLY, and give
** the command line you used to run the program, and
** any other information needed to repeat the problem.
** You may later be asked to upload data to help debug.

I have worked with Rick Reynolds on the issue and tried multiple things, none of which seem to work. He asked me to run suma and see if it opened a GUI (it did), then run -check_all. He asked me to run echo $DYLD_LIBRARY_PATH, and I got:
When I run afni on its own, it opens as normal.
When I run -dot_file_list, I get:
found under $HOME : .bash_profile
found under $HOME : .bashrc
found under $HOME : .cshrc
found under $HOME : .tcshrc
He looked at my .tcshrc files and said .tcshrc is overridden by .cshrc, so he asked me to edit them. When I tried that, we found out .tcshrc wasn’t under my ownership, so I got someone from IT to restore my ownership so I could make the edit. Then I ran the program again and got incomplete results still. I also found if I run bash SCRIPTNAME… or sh SCRIPTNAME… I get the same results.

The script takes about an hour to run. The command line to run the script looks like this:
$ sh /Users/bowdensa/Desktop/ [patient #] [patient #]resting.nii [patient #]anat.nii

The last three items are arguments I must give the computer. Shortly after the script begins, I must choose to run it using bash or tcsh. Tcsh never works (the program stops after about a minute), so I run it with bash and paste a line that looks like this:
tcsh -xef proc.[patient #] 2>&1 | tee output.proc.[patient #]

Any suggestions or insight is much appreciated!

Just as a follow up, I think this has been resolved over a quick zoom meeting.

Sarah, please let me know if that is not the case.


  • rick