AFNI crashing when using whereami


I am attempting to right click in the AFNI window and choose “- Where Am I?”. When I choose this, I don’t get an error in the command window but the AFNI windows all close.

If I try to run the whereami command in the command window, however, I get output. Any idea why it would be doing this?

Derek Archer

You don’t give enough information to even begin to think about the problem! This does not happen here, so there must be something peculiar about your system.

What is the crash message? What is the output of the command below? -check_all

Hello –

The output of the suggested command is below:

-------------------------------- general ---------------------------------
architecture:         64bit ELF
system:               Linux
release:              4.4.0-53-generic
version:              #74-Ubuntu SMP Fri Dec 2 15:59:10 UTC 2016
distribution:         Ubuntu 16.04 xenial
number of CPUs:       32
apparent login shell: bash
shell RC file:        .bashrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni           : /home/mcuser/abin/afni
afni version         : Precompiled binary linux_openmp_64: Nov 23 2016 
AFNI_version.txt     : AFNI_16.3.13, linux_openmp_64, Nov 23 2016
which python         : /usr/bin/python
python version       : 2.7.12
which R              : /usr/bin/R
R version            : R version 3.3.2 (2016-10-31) -- "Sincere Pumpkin Patch"
which tcsh           : /usr/bin/tcsh

instances of various programs found in PATH:
    afni   : 1   (/home/mcuser/abin/afni)
    R      : 1   (/usr/bin/R)
    python : 1   (/usr/bin/python2.7)

testing ability to start various programs...
    afni                 : success
    suma                 : success
    3dSkullStrip         : success      : success
    3dAllineate          : success
    3dRSFC               : success
    SurfMesh             : success

checking for R packages...
    rPkgsInstall -pkgs ALL -check : success

checking for $HOME files...
    .afnirc                   : missing
    .sumarc                   : missing
    .afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
++ module 'PyQt4' found at /usr/lib/python2.7/dist-packages/PyQt4
++ module loaded: PyQt4

-------------------------------- env vars --------------------------------
PATH = /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/mcuser/abin:/usr/lib/fsl/5.0

R_LIBS = /home/mcuser/R

LD_LIBRARY_PATH = /usr/lib/fsl/5.0:/usr/local/lib/


------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing suma_demo
data dir : missing FATCAT_DEMO
data dir : missing afni_handouts
atlas    : found TT_N27+tlrc  under /home/mcuser/abin

------------------------------ OS specific -------------------------------
which apt-get        : /usr/bin/apt-get
apt-get version      : apt 1.2.15 (amd64)

have Ubuntu system: Ubuntu 16.04 xenial

============================ summary comments ============================
*  login shell 'bash', trusting user to translate from 'tcsh'
*  shell bash: consider sourcing (non-login) .bashrc from (login) .profile
*  consider running: cp /home/mcuser/abin/AFNI.afnirc ~/.afnirc
*  consider running "suma -update_env" for .sumarc
*  insufficient data for AFNI bootcamp

Hi Derek,

Just to see, what happens if you unset LD_LIBRARY_PATH
and then try the same thing with the afni GUI?

  • rick

What is the result of “whereami -show_atlases” on the command line?

Hi Rick,

I unset the LD_LIBRARY_PATH and tried to access “Where Am I?” from the GUI. AFNI still shut down when I tried this.


Hi Daniel,

The output of whereami -show_atlases shows all of the atlases with a description next to it. The description for each atlas is as follows:


Could the error be a result of the two “//” before the atlas? So it’s looking for a path that doesn’t exist? How would I edit this?


I don’t think the double slashes are a problem, but are the atlas datasets actually there in that directory. If the datasets are stored in a separate directory, do this

setenv AFNI_ATLAS_PATH whatever_directory_the_atlases_happen_to_be

retry afni with that set (example for tcsh).

Hi, Daniel, Rick, and all,

I reported the same issue “AFNI crashing when using whereami” two times before, as well. To make it clear, I use SSH Shell to link my windows computer to the Linux server. When I used the old AFNI version, it is fine. The latest version never works with the “whereami” on my side.



It’s not clear he has exactly the same problem as you had. When I looked back at your old posts and compare, I find that Derek doesn’t say this was a remote access issue. If you’re still having problems, there may be a completely different problem and solution; the whereami GUI changed a while ago to support some clickable html links in the window. You can turn that off AFNI_WEBBY_WAMI set to NO. It might be the X11 server which runs remotely doesn’t handle something about that feature well.

Hi, Daniel,

But I do not know the method to set AFNI_WEBBY_WAMI “NO”. Does it mean that we set this in the resource or environment file? Any example for me?