3dZcutup failure in AFNI version AFNI_22.0.11

Dear AFNI group

I am using 3dZcutup to trim my fmri data. However, when I used the 3dZcutup (AFNI version of AFNI_22.0.11, should be the latest version) in the command line as the following:
/software/AFNI_22.0.11/3dZcutup -prefix test+orig -keep 1 36 fmap_for_fmri1_dir_AP+orig
I got the following error:
++ 3dZcutup: AFNI version=AFNI_22.0.11 (Feb 18 2022) [64-bit]
*** Nonsense values after -keep!
According to https://afni.nimh.nih.gov/pub/dist/doc/program_help/3dZcutup.html, I think I used the 3dZcutup correctly (please let me know if I didn’t).

I also tried 3dZcutup using an older AFNI version (AFNI_17.2.17), like the following:
/software/AFNI_17.2.17/abin/3dZcutup -prefix test+orig -keep 1 36 fmap_for_fmri1_dir_AP+orig
This time, 3dZcutup worked well.

It looks like the latest version of 3dZcutup doesn’t work like the old one. Is it a bug?


Hi Yixiang,

It looks like there was a typo in the error checking for that option. That will be fixed and made available tonight.
Please let me know if you need it sooner.

BTW, the fix is in, it just needs to be built.

Thanks for letting us know!

  • rick

Hi, Yixiang-

Hmm, OK.

Looking at the code, I think there is a mistake in how the inputs are read—right now, the program will only work if the 2 slice numbers are the same. Thanks for bringing this up. I will fix this and we will update the code.

Separately, I often use 3dZeropad with negative indices to cut away slices (rather than to add on zero-valued ones, as using positive values would):
or 3dAutobox:

But those might not suit your needs, and we obviously would like to fix the 3dZcutup program, anyways!


another instance of Rick getting the correct answer in before me…


Hi Rick and Taylor

I just tried 3dZcutup with the latest AFNI and it worked. Thank you for fixing that!


Great, glad it works, and thanks again for pointing it out.