3dVol2Surf projection shifted

Hi AFNI team,

I’m trying to project volume datasets to surface space using 3dVol2Surf and the project coordinates are shifted (on the y axis) for some reason. Please see the attached figure. In this figure, I used a different way for projection by letting suma and afni talk to each other, but the coordinates are shifted in the same way with 3dVol2surf. I use the following commands:

-spec std.141.TacFreqEnc01_lh.spec
-surf_A smoothwm
-surf_B pial
-sv TacFreqEnc01_SurfVol.nii
-grid_parent {lname}+orig. \ # the data I want to project -map_func mode \ -f_steps 10 \ -f_index nodes \ -out_niml TacFreqEnc01_{lname}_lh.niml.dset

Is there something I did wrong? I’ve tried redo the surf model, using raw anat files for the -sv option but all didn’t help…



If the surfaces were not generated for this anatomical dataset, then the sv volume should be the anatomical aligned to experiment output of @SUMA_AlignToExperiment. suma would be given the same -sv dataset on the command line. If the anatomical dataset is already the same used to generate the surfaces, then a dataset with no transformations in the header, usually the original anatomical dataset, would be used as the -sv dataset.

Hi Glen,

Thanks for the reply. I don’t quite understand your suggestion. Are you suggesting I should run @SUMA_AlignToExperiment?

The surface model was generated for the anatomy for this experiment. I’ve tried using SurfVol and raw anat file both as the -sv but all have this problem of shifting.

Can you clarify a bit on your advice, please? Thanks!


Hello Lingyan,

I think you have the gist of it. You shouldn’t have to run @SUMA_Align_To_Experiment, although it shouldn’t really hurt if the datasets are in the same space. My guess is that your datasets have some transformation in the header that is being applied on the transformation by the -sv volume or that the data is oblique. You can test for this by seeing how both volumes and surfaces look inside suma by adding a -vol mysvdset.nii.gz to the suma command line. You may want to show that command here too. To remove the obliquity considerations, make copies of all the datasets, maybe into a new directory. Then remove that information from the header (this is a destructive change, so do this only on copies) with “3drefit -deoblique mydsets”. If you can’t find a solution, you may send me the data, and I’ll take a look. Let me know what you would like to do.


Hi Daniel,

Thanks for your message.

I’ve tried the 3drefit option but it didn’t work.

When I fit the glm in afni, I used raw anatomy but not the SurfVol file. Could that be the problem?

I used 3dinfo to check SurfVol and my functional data and they seem to be in different spaces…

It seems I can only attach 1 file in this webpage and it has a limit in size and format… I hope to send you the related files and you can take a look.

Thanks a lot!


I’ll PM you with instructions on uploading data.