3dUndump and using wildcard characters (*)

When using 3dUndump, can wildcard characters (e.g., *) be used in the path name?

echo ${TEST}
echo “${Broca_Coor}” | 3dUndump -prefix D_111_Wrk_NativeLoc -srad 1 -orient LPI -master ${TEST}/stats.D_111_REML+orig -xyz -

++ 3dUndump: AFNI version=AFNI_23.0.04 (Feb 13 2023) [64-bit]

** glob error: No such file or directory

** You may need to ‘setenv AFNI_SHELL_GLOB YES’


** In particular, if you are trying to access an NFS (network file

** system) mounted drive, you might be running into the situation

** where the NFS ‘cookie’ length on the remote system does not

** match the cookie length on your local system – this is the only

** situation in which we have ever seen this error. In that case,

** you can either set the environment variable as described above,

** or fix the cookie length mismatch by changing the way the NFS

** drive is exported.


** The following information from Graham Wideman of UCSD might also

** be helpful if you are reading this ‘glob error’ message:


** I’ve changed the NFS export settings on our Mac OS X 10.5 server

** to include the ‘-32bitclients’ option, and can confirm that

** this does cause AFNI to be able to see files that it could not

** see without this option. So this appears to be the more general

** way to fix the problem.


** For others in the same boat who may stumble on this message:

** It’s not at all obvious how to actually set this option,

** as OS X 10.5’s Server Admin NFS settings panels don’t have

** any way to do it.


** The short story is:

** You have to edit the /etc/exports file, as per usual in Unix,

** but decidedly not in line with all other SharePoint related

** settings in 10.5. But first, in order to have the edits not

** conflict with Server Admin management of those settings, you

** have to uncheck Server Admin’s ‘NFS Enabled’ checkbox for the

** relevant shares. Then, when editing the exports file, move

** the relevant lines outside the ‘Server Admin managed’ brackets,

** and add your options. In general, such options have to go in

** the middle section of a line; for example, after the path.

** Example:


** /Somedir -32bitclients -maproot=nobody -sec=sys -network -mask

** FATAL ERROR: -master: can’t open dataset

has context menu


At a glance, that looks okay, because while the shell fails to match it, an AFNI program could (via the AFNI library).
But since you are using a wildcard, it must exactly match a file name on disk. So try adding .HEAD at the end of the REML+orig dataset name.

Of course, adding .HEAD will probably mean that the shell will then succeed in matching it in the 3dUndump command, and then the AFNI library will never see the ‘*’.

In any case, try using a complete file name.

  • rick

Thanks - moving to next item on the debugging list