3dmaskave for slices in y direction

I want to get an average beta value for each slice along an ROI. I saw that 3dmaskave’s -slice option only goes in the z-direction, but in my data slices are in the y-direction. I am currently trying to do it using 3dmaskdump, but that gives me many betas and I would need to average them afterwards. Is there a better way to do this? this is my current 3dmaskdump command to get values from where y=17:

3dmaskdump -mask …/…/ROIs.nii_ANTS+tlrc. -mrange 13 24 -xyz -cmask ‘-a …/…/ROIs.nii -expr 1-bool(j-17)’ -o test stats.101_ANTS+tlrc.

The slice direction is the definition of the z direction,
however slices are stored on disk. Can you be more
specific as to what you mean by slices being in the y
direction? Did you resample/reorient the data?

  • rick

to my knowledge I haven’t resampled/reoriented the data. Here is the orientation info when I 3dinfo my data:
Data Axes Tilt: Plumb
Data Axes Orientation:
first (x) = Anterior-to-Posterior
second (y) = Superior-to-Inferior
third (z) = Left-to-Right [-orient ASL]

Is that what you would expect?

I’m confused about how to determine which slices I want. When the z-value changes in the AFNI window, the cursor moves along the dorsal/ventral axis as seen here: Image 1[/url] [url=http://imgur.com/kjl0b1L]Image 2. That’s not what I think of as slices-- I would expect the cursor to move in an anterior-posterior direction. It’s possible that I’m thinking about this the wrong way, but I’d appreciate your input!

The coordinates in the AFNI GUI are actually
irrelevant, as they are given in a “standard”
orientation (either RAI or LPI, say). That is
so that a brain looks like a brain, and those
coordinates mean the same thing across
subjects and datasets per subject.

Your slices are left to right, so that is what
3dmaskave would use with the -slices option.

So you were planning to class 3dmaskave
repeatedly, once for each slice? That should

  • rick

To be clear, I was trying to run 3dmaskave on chunks of slices in the anterior to posterior dimension. I didn’t want LTR or inferior to superior slices, so I reoriented the data. I didn’t realize that slices are in the z-dimension by default. so I made anterior/posterior the z dimension and then ran 3dmaskave. thanks for your help!