3dLMEr ?issue with R version

Hi AFNI team,

I have within-subject resting-state fMRI data in controls (ctrl) and patients (pat, factor: group) under drug (d2) and placebo (p2, factor: cond).
There is a random effect of subject (Subj).

I am interested in brain regions that show an interaction effect of cond*group.

I have specified the following in 3dLMEr:

3dLMEr -prefix 3dLMErmodel -jobs 12
-model ‘condgroup+(1|Subj)’
-gltCode d2 'cond : 1
-gltCode p2 ‘cond : 1p2’
-gltCode int 'cond : 1
d2 -1p2 group : 1pat -1*ctrl’
-dataTable @dataframe_streamlined

The data table (I’ve abbreviated this) has the structure:

[b]Subj cond group InputFile
MOA101 d2 pat /home/MOA101d2+tlrc
MOA102 d2 pat /home/MOA102d2+tlrc
MOA301 d2 ctrl /home/MOA301d2+tlrc
MOA302 d2 ctrl /home/MOA302d2+tlrc
MOA101 p2 pat /home/MOA101p2+tlrc
MOA102 p2 pat /home/MOA102p2+tlrc
MOA301 p2 ctrl /home/MOA301p2+tlrc
MOA302 p2 ctrl /home/MOA302p2+tlrc [/b]

When I run the code I get as far as:

If the program hangs here for more than, for example, half an hour,
kill the process because the model specification or something else
is likely inappropriate.

Loading required package: lmerTest
Loading required package: lme4
Loading required package: Matrix

Attaching package: ‘lmerTest’

The following object is masked from ‘package:lme4’:


The following object is masked from ‘package:stats’:


Loading required package: phia
Loading required package: car
Loading required package: carData

… after which the code hangs. When I run afni_system_check.py -check_all I get the following:

-------------------------------- general ---------------------------------
architecture: 64bit ELF
system: Linux
release: 4.18.0-372.32.1.el8_6.x86_64
version: #1 SMP Tue Oct 25 05:53:57 EDT 2022
distribution: ubuntu 22.04 Jammy Jellyfish
number of CPUs: 48
apparent login shell: tcsh (current shell is bash)
shell RC file: .cshrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /opt/afni/afni
afni version : Precompiled binary linux_ubuntu_16_64: Oct 13 2022
: AFNI_22.3.03 ‘Lucius Verus’
AFNI_version.txt : AFNI_22.3.03, linux_ubuntu_16_64, Oct 13 2022
which python : /usr/bin/python
python version : 3.10.6
which R : /usr/bin/R
R version : R version 4.1.2 (2021-11-01) – “Bird Hippie”
which tcsh : /usr/bin/tcsh

instances of various programs found in PATH:
afni : 1 (/opt/afni/afni)
R : 1 (/usr/bin/R)
python : 1 (/usr/bin/python3.10)
python2 : 0
python3 : 1 (/usr/bin/python3.10)

** have python3 but not python2

testing ability to start various programs…
afni : success
suma : success
3dSkullStrip : success
uber_subject.py : success
3dAllineate : success
3dRSFC : success
SurfMesh : success
3dClustSim : success
3dMVM : success

checking for R packages…
rPkgsInstall -pkgs ALL -check : success

R RHOME : /usr/lib/R

checking for $HOME files…
.afnirc : found
.sumarc : found
.afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** failed to load module PyQt4
– PyQt4 is no longer needed for an AFNI bootcamp

++ module loaded: matplotlib.pyplot
module file : /usr/lib/python3/dist-packages/matplotlib/pyplot.py
matplotlib version : 3.5.1

-------------------------------- env vars --------------------------------
PATH = /opt/afni:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

R_LIBS = /opt/R

LD_LIBRARY_PATH = /.singularity.d/libs


------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /opt/afni

------------------------------ OS specific -------------------------------
which apt-get : /usr/bin/apt-get
apt-get version : apt 2.4.8 (amd64)

have Ubuntu system: ubuntu 22.04 Jammy Jellyfish
have Ubuntu afni : Precompiled binary linux_ubuntu_16_64: Oct 13 2022

========================= summary, please fix: =========================

  • shell bash: MISSING login setup file, e.g. .bash_profile
  • shell bash: MISSING non-login setup file .bashrc
  • shell bash: consider sourcing (non-login) .bashrc from (login) .bash_profile
  • insufficient data for AFNI bootcamp
    (see “Prepare for Bootcamp” on install pages)

The R version as above is 4.1.2.

I would be grateful if you have any suggestions about why the code is hanging at that point. Is it to do with the model specification, the structure of the data table, or about the version of R I have?

Many thanks,

This issue appears be caused by all the input files containing only zero values.