3dLME contrast error

Hi there,

I’m attempting to use 3dLME to model the interaction between two within-subject categorical variables and the linear and quadratic effect of age (this is a longitudinal study). When running the following model without specifying contrasts, it is estimated without problem.

3dLME -prefix SelfOverTime_3Ts -jobs 8
-model “targetdomainage_c+targetdomainage_c2”
-ranEff ‘~1’
-SS_type 3
-qVars “age_c,age_c2”
-qVarCenters “0,0”
-mask /path/mask.nii
Subj target domain age_c age_c2 InputFile
s005 self academic -3.09016393442623 9.54911314162859 /path/s005_t1_con_0001.nii
s005 self social -3.09016393442623 9.54911314162859 /path/s005_t1_con_0002.nii
s005 other academic -3.09016393442623 9.54911314162859 /path/s005_t1_con_0003.nii
s005 other social -3.09016393442623 9.54911314162859 /path/s005_t1_con_0004.nii
s005 self academic -0.0273972602740002 0.000750609870521312 /path/s005_t2_con_0001.nii
s005 self social -0.0273972602740002 0.000750609870521312 /path/s005_t2_con_0002.nii
s005 other academic -0.0273972602740002 0.000750609870521312 /path/s005_t2_con_0003.nii
s005 other social -0.0273972602740002 0.000750609870521312 /path/s005_t2_con_0004.nii
s005 self academic 3.6602739726027 13.3976055545127 /path/s005_t3_con_0001.nii
s005 self social 3.6602739726027 13.3976055545127 /path/s005_t3_con_0002.nii
s005 other academic 3.6602739726027 13.3976055545127 /path/s005_t3_con_0003.nii
s005 other social 3.6602739726027 13.3976055545127 /path/s005_t3_con_0004.nii \

However, when adding contrasts to the model, it fails to run (standard error message). All of the necessary packages were installed, and I believe the contrasts are correctly specified. I’ve tried to run a model with the following contrasts:

-num_glt 6 \
-gltLabel 1 'self-other' -gltCode  1 'target : 1*self -1*other' \
-gltLabel 2 'social-academic' -gltCode  2 'domain : 1*social -1*academic' \
-gltLabel 3 'age self-other' -gltCode  3 'target : 1*self -1*other age_c : ' \
-gltLabel 4 'age^2 self-other' -gltCode  4 'target : 1*self -1*other age_c2 : ' \
-gltLabel 5 'age social-academic' -gltCode  5 'domain : 1*social -1*academic age_c : ' \
-gltLabel 6 'age^2 social-academic' -gltCode  6 'domain : 1*social -1*academic age_c2 : ' \

Since that model failed though, I also tried running a model with this simple contrast alone:
-num_glt 1
-gltLabel 1 ‘self’ -gltCode 1 ‘target : 1*self’ \

Could you provide any guidance as to what I might be doing wrong?

Thank you very much for your help!

What’s the output of the following command?

rPkgsInstall -pkgs ALL -check

Hi Gang,

Thank you very much for the advice. Running this command alerted us to the fact that we were missing the “afex” and “paran” packages. I didn’t see either of those packages listed as dependencies on the 3dLME help guide, but since it’s running now, looks like they were necessary nonetheless.

Thank you again for your help and for your quick response!