3dISC test - "Error in checkForRemoteErrors(val)"


I am testing out the new 3dISC program with a few subjects and different inputs to get a feel for how it works. I am currently just trying to run a very basic 1 group ISC analysis on 3 subjects to see if I can get it running. This is my input:

bash-4.4$ 3dISC -prefix ISC -jobs 12 \

-model ‘1+(1|Subj1)+(1|Subj2)’
Subj1 Subj2 InputFile
667 669 Tcorr667_669+orig
667 671 Tcorr667_671+orig
669 671 Tcorr669_671+orig

which starts up fine, but when I run it I get this output and error:

updating R_LD_LIBRARY_PATH …

***** Summary information of data structure *****
2 subjects in set1 : 667 669
2 subjects in set2 : 669 671
3 subjects in total: 667 669 671
3 response values

Contingency tables of subject distributions among the categorical variables:

***** End of data structure information *****

Reading input files now…

Reading input files for effect estimates: Done!

Warning message:
In is.na(lop$vVars) :
is.na() applied to non-(list or vector) of type ‘NULL’
If the program hangs here for more than, for example, half an hour,
kill the process because the model specification or something else
is likely inappropriate.

Loading required package: lme4
Loading required package: Matrix
Warning message:
package ‘lme4’ was built under R version 3.4.4
[1] “Great, test run passed at voxel (30, 36, 30)!”
[1] “Start to compute 91 slices along Z axis. You can monitor the progress”
[1] “and estimate the total run time as shown below.”
[1] “10/01/19 18:16:17.005”
Loading required package: snow
Package snow loaded successfully!

Z slice # 1 done: 10/01/19 18:16:23.004
Z slice # 2 done: 10/01/19 18:16:23.062
Z slice # 3 done: 10/01/19 18:16:23.086
Error in checkForRemoteErrors(val) :
2 nodes produced errors; first error: object ‘fm’ not found
Calls: aperm … clusterApply → staticClusterApply → checkForRemoteErrors
Execution halted

I looked up the checkForRemoteErrors function and it seems like something internal that can’t be called by the user. Is there anyway to get around this error?

Thanks so much!


Ryann, try testing it with at least 5 subjects and see if you still have the same issue.

Ran it with 5 subjects and it worked like a charm! Thanks!

Gang Wrote:

Ryann, try testing it with at least 5 subjects and
see if you still have the same issue.