3dICC error in is.null(ss), calls: read.ICC.opts.batch -> parse.AFNI.args -> is.num.string

Dear Gang & AFNI team,

I was trygint o run 3dICC today, when the program stopped (immediately) with the following error:

Error in is.null(ss) || !length(ss) || ss == "" :
  'length = 284' in coercion to 'logical(1)'
Calls: read.ICC.opts.batch -> parse.AFNI.args -> is.num.string
Execution halted

The full call was:

3dICC -prefix ICC/breathhold_optcom_cvr_1.nii.gz -jobs 10 -mask MNI/MNI_GM_mask.nii.gz -model  '1+(1|session)+(1|Subj)' -tStat 'tFile' -dataTable      Subj session    tFile                           InputFile                  001  01  norm/001_01_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/001_01_breathhold_optcom_ntrial-1_cvr.nii.gz      001  02  norm/001_02_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/001_02_breathhold_optcom_ntrial-1_cvr.nii.gz      001  03  norm/001_03_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/001_03_breathhold_optcom_ntrial-1_cvr.nii.gz      001  04  norm/001_04_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/001_04_breathhold_optcom_ntrial-1_cvr.nii.gz      001  05  norm/001_10_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/001_10_breathhold_optcom_ntrial-1_cvr.nii.gz      002  01  norm/002_01_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/002_01_breathhold_optcom_ntrial-1_cvr.nii.gz      002  02  norm/002_02_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/002_02_breathhold_optcom_ntrial-1_cvr.nii.gz      002  03  norm/002_03_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/002_03_breathhold_optcom_ntrial-1_cvr.nii.gz      002  04  norm/002_04_breathhold_optcom_ntrial-1_tstat.nii.gz  norm/002_04_breathhold_optcom_ntrial-1_cvr.nii.gz      002  05

The AFNI version, compiled in a container, is:

Precompiled binary linux_ubuntu_16_64_glw_local_shared: May  9 2023 (Version AFNI_22.3.07 'Lucius Verus')

Unfortunately I did not manage to interpret the error myself, and I wouldn’t be able to pinpoint it better.
The other unfortunate thing is that I run this code without any problem on a different version of the same container (Built on April 21 2023).

What could be the issue behind it?

Thank you,

Hello Stefano,

I bumped into the same error as you and was wondering if you had any chance in solving this problem ?

Personally, my script worked on a different machine.
SO it would probably be related to some R version .

It could be related to your AFNI version and/or R version. Please let us know if 3dICC continues to encounter issues after you perform the upgrades.


I effectively got the same Error on running 3dISC yesterday that terminated the execution. I wonder if it is related to a new R feature that is a good change but may require a revision of the 3dLME family in the use of the II operator for the option test for arrays of length > 1.

Please see R Warning 'length(x) = 2 > 1' in coercion to 'logical(1)' - Stack Overflow

Call and warning:
3dISC -prefix ISC -jobs 20 -model 1+(1|Subj1)+(1|Subj2) -dataTable Subj1 Subj2 InputFile s4 s6 4_6_Corr+tlrc s4 s10 4_10_Corr+tlrc s4 s14 4_14_Corr+tlrc s4 s18 4_18_Corr+tlrc s4 s21 4_21_Corr+tlrc s4 s22 4_22_Corr+tlrc s4 s23 4_23_Corr+tlrc s4 s16 4_16_Corr+tlrc s4 s20 4_20_Corr+tlrc s4 s27 4_27_Corr+tlrc s6 s10 6_10_Corr+tlrc s6 s14 6_14_Corr+tlrc s6 s18 6_18_Corr+tlrc s6 s21 6_21_Corr+tlrc s6 s22 6_22_Corr+tlrc s6 s23 6_23_Corr+tlrc s6 s16 6_16_Corr+tlrc s6 s20 6_20_Corr+tlrc s6 s27 6_27_Corr+tlrc s10 s14 10_14_Corr+tlrc s10 s18 10_18_Corr+tlrc s10 s21 10_21_Corr+tlrc s10 s22 10_22_Corr+tlrc s10 s23 10_23_Corr+tlrc s10 s16 10_16_Corr+tlrc s10 s20 10_20_Corr+tlrc s10 s27 10_27_Corr+tlrc s14 s18 14_18_Corr+tlrc s14 s21 14_21_Corr+tlrc s14 s22 14_22_Corr+tlrc s14 s23 14_23_Corr+tlrc s14 s16 14_16_Corr+tlrc s14 s20 14_20_Corr+tlrc s14 s27 14_27_Corr+tlrc s18 s21 18_21_Corr+tlrc s18 s22 18_22_Corr+tlrc s18 s23 18_23_Corr+tlrc s18 s16 18_16_Corr+tlrc s18 s20 18_20_Corr+tlrc s18 s27 18_27_Corr+tlrc s21 s22 21_22_Corr+tlrc s21 s23 21_23_Corr+tlrc s21 s16 21_16_Corr+tlrc s21 s20 21_20_Corr+tlrc s21 s27 21_27_Corr+tlrc s22 s23 22_23_Corr+tlrc s22 s16 22_16_Corr+tlrc s22 s20 22_20_Corr+tlrc s22 s27 22_27_Corr+tlrc s23 s16 23_16_Corr+tlrc s23 s20 23_20_Corr+tlrc s23 s27 23_27_Corr+tlrc s16 s20 16_20_Corr+tlrc s16 s27 16_27_Corr+tlrc s20 s27 20_27_Corr+tlrc
Error in is.null(ss) || !length(ss) || ss == "" :
'length = 168' in coercion to 'logical(1)'
Calls: read.ISC.opts.batch -> parse.AFNI.args -> is.num.string
Execution halted


What is your AFNI version (afni -ver)? It's possible that you might need to update your AFNI.


So old, Gang, Oct 2022. :upside_down_face:
<We are using a secure, offline environment for this machine.>
I'll ask our sysad to update it. Glad to see it be a nothing burger!