3dDeconvolve with many regressors

I have many regressors I want to use in 3dDeconvolve (~72). There are all in a matrix .1D format. it is impractical to name them all using -stim_file option. Is there a way to pass the whole matrix in? I have been using -ortvec for passing a bunch of baseline regressors this way but for the main regressors I am not aware of such option.

In this case I am only interested in beta values (not the statistics) so I thought I can use -ortvec for my regressors and the ask 3dDeconvolve to output baseline betas using -bout. I wanted to avoid outputting other stats to keep file size undercontrol so I said -nobucket and used -cbucket. The analysis finished after sometime but afni didnot output anything for me (I guess I am using conflicting options). Here is the command I used and afni finished execution without errors and matrix conditions were evaluated to be very good ( the regressors I am interested in are in tcat_stim_combine_persetmem_withFV.1D)

3dDeconvolve -input dspk_detrend_pct_tcat_in_D99+tlrc
-mask D99_template_FuncGrid+tlrc
-polort -1
-num_stimts 0
-concat tcat_concat.1D
-censor tcat_censor_kmeans_withFV.1D
-ortvec tcat_stim_combine_persetmem_withFV.1D stimcond
-ortvec tcat_motion.1D motion
-ortvec tcat_motion_deriv.1D motion_deriv
-bout -nobucket -noFDR -allzero_OK -GOFORIT 7
-cbucket dspk_detrend_pct_tcat_in_D99_betas_censorkmeans_withFV_rbebase

The -cbucket dataset comes with the -bucket dataset, so
you might just create both and delete the bucket afterwards.

  • rick

I realized I should not use -nobucket because nothing was output in this case. removing that and keeping -cbucket option worked fine.