3dDeconvolve.err when using * fillers in


When using 3dDeconvolve I get the following errors when using fillers (i.e. *) in rows not containing any trial events in a run. What is curious to me is that it asks if the fillers are global times, when all the stimtimes are local, and why should it matter if the fillers are global or local?

Also, I frequently get the other error below, in that AFNI seems to think that there are duplicate times when I am using identical times in separate runs which are separated by a filler row.

Thanks for any help you can provide!

+ WARNING: ‘-stim_times 3’ (GLOBAL) has 3 '’ fillers; do you want LOCAL times?
*+ WARNING: ‘-stim_times 3’ file ‘stimuli/03.BirdSSp.1D’ has 1 duplicate and 0 near-duplicate times ???
+ WARNING: ‘-stim_times 4’ (GLOBAL) has 3 '’ fillers; do you want LOCAL times?
*+ WARNING: ‘-stim_times 4’ file ‘stimuli/04.BirdST.1D’ has 1 duplicate and 0 near-duplicate times ???

It is not clear what errors you mean, but it seems like perhaps the
stim classes only have single events per run, and then the timing
files have only single numbers per row, including *.

In that case the files would be considered to be global timing
ones, unless you specify otherwise.

Would you please show us examples of the files that are
leading to the given errors or warnings?


  • rick

Hi Rick: here is an example of the error message. The contents of file SSp are below. In the case of this particular participant, there was only one event recorded for the SSp condition (in run 6). All the other five runs were empty for this condition.

** warnings for local stim_times format of file SSp.1D

  • single column looks local from ‘*’,
    but 3dDeconvolve would interpret as global


All the times are considered as global times for a single column of numbers. Here, it sounds like you want local times defined instead. You could do that by adding an extra asterisk to the last line as suggested in an extract from an old 3dDeconvolve document (shown below) or use the option -local_times with 3dDeconvolve.


In the situation where you are using multi-row input, AND there is at most one actual stimulus per run, then you might think that the correct input would be something like:
However, this will be confused with the 1 column format, which means global times, and so this is wrong. Instead, you can put an extra '*' on one line with an actual stimulus, and then things will work OK:
  30 *


It should be sufficient to even have the first line read:

  • rick